Acura TSX 2004 Navi - Radio Power Issue - Acura TSX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-17-2017, 04:38 PM Thread Starter
Registered Member
 
Join Date: Mar 2017
Posts: 1
 
iTrader: (0)
Acura TSX 2004 Navi - Radio Power Issue

Hello,

I am currently having an issue with my radio, it will not turn on. The display for the time is also non-existent. Below are some methods I have tried:

1) Checked ALL fuses, none blown out. Radio still not working.

2) Held the CD/AUX button to apparently reset? Nothing happens.

3) Removed battery cables. Temporarily, worked initially. Afterwards, back to no power. I don't know if it has any relevance but on start-up after the reset the time kept flashing in and out. The second time I start my car (and every other time after), zero power to the radio. I can't even hear the cd disc changing.

The PCB was swapped 6 years ago, wondering if that's the issue again now. I wasn't covered under the warranty at the time so I had to pay around 2 thousand to get it fixed, trying to avoid paying for that again. My Navi works perfectly fine, just the radio doesn't power on and my display time is gone. Can anyone give me any clarity on this matter?
havikeke is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Acura TSX Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome