CEL Code P0420, Please Help Me Resolve It - Acura TSX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-19-2009, 08:04 AM Thread Starter
Registered Member
 
Join Date: May 2009
Posts: 28
 
iTrader: (0)
CEL Code P0420, Please Help Me Resolve It

So two weeks ago, my CEL came on while I was driving rather tamely. I took it to an exhaust shop, because I figured the light was probably due to a leak. They pulled the code P0420, "Catalyst System Efficiency Below Threshold (Bank 1)." They said there were no leaks and that the catalyst must have failed and I should replace it. I told them to reset the code and I would see what happened.

Yesterday the light came back on, and I am sure it is the same code (although I will have it checked later today). I have Comptech Headers, an RT Cat, and a Comptech Cat-Back. I'm currently at 35k miles and all of those parts have been on since 3k miles. Is there really a chance that they just suddenly went bad? I have never had a CEL before so I'm not sure why it would start now.

I know I could just get a non-fouler to trick the O2 sensor, but I am worried that there is something actually wrong with the car. The reason for this being that I have been getting worse gas mileage than historically and my engine has been noisy at idle and certain RPMs. Any ideas as to what else might be causing this?

I don't want to just take the car to the shop and say "I think something is wrong" because they will come up with some marvelous reason for me to shell out a grand.

Thanks
madmanmax3000 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-19-2009, 08:26 AM
Registered Member
 
falken's Avatar
 
Join Date: Jul 2008
Location: belgium (europe)
Posts: 276
 
iTrader: (0)
if the light go's on you will drink more fuel per mile
its normal (safety mode is running much richer)
falken is offline  
post #3 of 7 (permalink) Old 05-19-2009, 08:29 AM
iVTEC no koe
 
HoRRo's Avatar
 
Join Date: Oct 2005
Location: Toronto, Canada
Posts: 1,913
        
iTrader: (0)
Cheapest, quickest fix (considering you run RT cat), is just to get the defouler.

I run RT cat and defouler. Initially I had the same CEL, but after defouler, it's gone.

At worst case, your O2 sensor is toast, even then, it's not too much to replace.

My car is stock, I promise.

Last edited by HoRRo; 05-19-2009 at 08:29 AM. Reason: o2 added.
HoRRo is offline  
post #4 of 7 (permalink) Old 05-19-2009, 08:52 AM Thread Starter
Registered Member
 
Join Date: May 2009
Posts: 28
 
iTrader: (0)
Okay, makes sense that the car would run richer when it knows the light is on...

What's the story with the correct non-fouler to buy? Do I want the Napa 730-2442 or the Help! 42009/42002?

Still, does it not seem weird that these parts wouldn't give me a CEL until now?
madmanmax3000 is offline  
post #5 of 7 (permalink) Old 05-19-2009, 09:33 AM
iVTEC no koe
 
HoRRo's Avatar
 
Join Date: Oct 2005
Location: Toronto, Canada
Posts: 1,913
        
iTrader: (0)
Quote:
Originally Posted by madmanmax3000 View Post
Okay, makes sense that the car would run richer when it knows the light is on...

What's the story with the correct non-fouler to buy? Do I want the Napa 730-2442 or the Help! 42009/42002?

Still, does it not seem weird that these parts wouldn't give me a CEL until now?
O2 sensors and high-flow cats are always weird. Some people can run them without defoulers, some need them from the moment they install the cat, others after while from installing the cat. Can't explain it.


I bought mine from strutking, but it appears he doesn't sell them anymore. Here is an angled one on ebay:

O2 SENSOR ANGLE ADAPTER EXTENSION UNIVERSAL 02 CEL:eBay Motors (item 250426150662 end time May-23-09 20:33:09 PDT)

Or a branded one, Blox:

http://www.prostreetonline.com/x/blo...eliminator.asp

Or a site (acquired from 8thcivic.com):

http://www.mechanicalo2sim.com/

Straight Sim $14 Shipped
Angled Sim $25 Shipped

My car is stock, I promise.

Last edited by HoRRo; 05-19-2009 at 09:36 AM. Reason: more links
HoRRo is offline  
post #6 of 7 (permalink) Old 05-19-2009, 10:07 AM
Registered Member
 
Join Date: Jun 2008
Posts: 256
     
iTrader: (1)
had the same code on my s2k, at first i thought it was bad gas, but it came on again when I didn't tighten the gas cap past 3 clicks. Never happened again after I make sure I tighten the gas cap. Similar mods on my s2k.
HKSSupra91 is offline  
post #7 of 7 (permalink) Old 05-19-2009, 11:39 AM Thread Starter
Registered Member
 
Join Date: May 2009
Posts: 28
 
iTrader: (0)
Thanks for the links Horro, I will probably end up getting one of those. However, I need the part before Friday (traveling for Mem. Day), so I will get a $5 piece and modify it in the meanwhile.

HKSSupra, I thought it was the gas cap too the last time this happened, but I've been careful since. I think I need the defouler now.

So Napa and Help! both work fine? One is not better than the other?
madmanmax3000 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Acura TSX Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome