Power Steering Leak - Acura TSX Forum
Home Forums Register Go Premium Garage Photo Gallery FAQ Auto Loans Members List vBGarage Mark Forums Read Auto EscrowInsurance


Go Back   Acura TSX Forum > Welcome > TSX Problems and Fixes > 1st Gen - Problems and Fixes

Welcome to TSXClub.com!
Welcome to TSXClub.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join TSXClub.com today!


Reply
 
LinkBack Thread Tools Display Modes
Old 06-04-2009, 02:30 AM   #1 (permalink)
I Heart my TSX !!!!
 
Join Date: Jul 2008
Location: Bismarck, ND
My Ride: 2004 Acura TSX
Posts: 197
04TSX04 is neutral and has a clean balanced record.
iTrader: (0)

Power Steering Leak

Whats going on members,

I have a power steering leak and it is boggeling my mind, the boot that goes at the end of the tie rod end and the steering gearbox on the passanger side seems to have some power steering fluid that drips from the bottom of the boot,

I have checked all the power steering hoses and the boot on the end the the tie rod end and there are no holes or rips on the boot and the steering gearbox has no wet fluid on it either, so I know my steering gearbox seems to be fine, I don't know where the leaks are coming from, there are no leaks under the hood either.

any help would be appreciated

Thank you
04TSX04 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-04-2009, 04:28 AM   #2 (permalink)
Registered Member
 
Join Date: May 2008
Location: Brooklyn NY
My Ride: Acura Tsx 2008 no Navy Auto
Posts: 347
silver08tsx has a slight shameless behaviour in his/her past.
iTrader: (0)

Lol my mechanic told me a story of this dude power steering leaking all in the booth. They couldn't find where all the liquid was going until by accident he touched the booth and it was hard. Not sure what was the problem if i remember ill let you know.
silver08tsx is offline   Reply With Quote Quick reply to this message
Old 06-04-2009, 10:06 AM   #3 (permalink)
Registered Member
 
Join Date: Apr 2009
My Ride: tsx/2005/Pearl
Posts: 50
onebadtsx can only hope to improve, or face mass condemn.
iTrader: (0)

I have the same problem. I'm taking my car in next week to local independent dealer that specializes in alignments. I went by Acura just to get an idea of the cost. Guy told me Rack and Pinion cost 1400.00 and that's without install labor. When fluid is leaking from the boot its common to replace the whole rack and pinion. Buddy of mine told me that I can get a refurbished one from Advanced for 330.00. I will keep you updated when I take it in next week. Hopefully they can just replace a seal and be done with this.
onebadtsx is offline   Reply With Quote Quick reply to this message
Old 06-04-2009, 11:28 AM   #4 (permalink)
I Heart my TSX !!!!
 
Join Date: Jul 2008
Location: Bismarck, ND
My Ride: 2004 Acura TSX
Posts: 197
04TSX04 is neutral and has a clean balanced record.
iTrader: (0)

Quote:
Originally Posted by onebadtsx View Post
I have the same problem. I'm taking my car in next week to local independent dealer that specializes in alignments. I went by Acura just to get an idea of the cost. Guy told me Rack and Pinion cost 1400.00 and that's without install labor. When fluid is leaking from the boot its common to replace the whole rack and pinion. Buddy of mine told me that I can get a refurbished one from Advanced for 330.00. I will keep you updated when I take it in next week. Hopefully they can just replace a seal and be done with this.

From what I can tell there is no hole in the boot, and no wet or fluid from the seal, that is what is boggeling my mind LOL.

and if it was the rack and pinion, would it be leaking from the driver side also ??
04TSX04 is offline   Reply With Quote Quick reply to this message
Old 06-04-2009, 01:40 PM   #5 (permalink)
I Heart my TSX !!!!
 
Join Date: Jul 2008
Location: Bismarck, ND
My Ride: 2004 Acura TSX
Posts: 197
04TSX04 is neutral and has a clean balanced record.
iTrader: (0)

I called Bloomington Acura, In Minnesota, since Bismarck, ND does not have an Acura dealership ( yes its sucks LOL ),

I explained to the service manager what was going on, and he said its not very comon (SP) for the rack and pinion to go out in the TSX, unless he was feeding me a line of BS, I think I am going to just keep the PS resovour full, untill I can figure out the exact problem.

The good thing is it's not leaking alot, about a dime drop of PS fluid, I think I am just going to jack up my car, clean off the boot really good, start up the car and have a friend turn the wheel and see if I can find where the leak is coming from.

Thank for all the answers members !! I really appreciate it alot
04TSX04 is offline   Reply With Quote Quick reply to this message
Old 06-04-2009, 02:45 PM   #6 (permalink)
(9)
Moderator Emeritus
 
endlesswinterco's Avatar
 
Join Date: Apr 2008
Location: Charm City
My Ride: 2006 ABP & 2011 CBP Wagon
Posts: 2,360
endlesswinterco is on the distinguished road to high status recognition.endlesswinterco is on the distinguished road to high status recognition.endlesswinterco is on the distinguished road to high status recognition.endlesswinterco is on the distinguished road to high status recognition.endlesswinterco is on the distinguished road to high status recognition.endlesswinterco is on the distinguished road to high status recognition.endlesswinterco is on the distinguished road to high status recognition.
iTrader: (12)

posted on HT about this.
__________________
resigned from Mod duties....no time!

Currently:
2006 ABP
2011 CBP Tech Wagon
endlesswinterco is offline   Reply With Quote Quick reply to this message
Old 06-04-2009, 03:07 PM   #7 (permalink)
I Heart my TSX !!!!
 
Join Date: Jul 2008
Location: Bismarck, ND
My Ride: 2004 Acura TSX
Posts: 197
04TSX04 is neutral and has a clean balanced record.
iTrader: (0)

Quote:
Originally Posted by endlesswinterco View Post
posted on HT about this.
Yes I did, just wanted to see if anyone here had the same problem or have a fix aswell, I will try your suggestion endlesswinterco tonight and let you know as soon as I find the answer, Thanks again I really appreciate it.
04TSX04 is offline   Reply With Quote Quick reply to this message
Old 06-19-2009, 09:56 PM   #8 (permalink)
*Metalhead*
 
1TSXer's Avatar
 
Join Date: Oct 2004
Location: Sachse, Texas
My Ride: '12 GM 370Z T/S/Navi, '04 RYP S2000, 2010 CBP RDX
Posts: 2,657
1TSXer is either reputation whoring, or truly reaching the elite club.1TSXer is either reputation whoring, or truly reaching the elite club.1TSXer is either reputation whoring, or truly reaching the elite club.1TSXer is either reputation whoring, or truly reaching the elite club.1TSXer is either reputation whoring, or truly reaching the elite club.1TSXer is either reputation whoring, or truly reaching the elite club.1TSXer is either reputation whoring, or truly reaching the elite club.1TSXer is either reputation whoring, or truly reaching the elite club.
iTrader: (6)

I had this same problem and took mine to the dealer. They said the rack needs to be replaced. $1,600 Bucks is what it's going to cost me! Mine was leaking from the boot that connects to the rack and pinion box on the driver's side.
__________________
2004 RYP S2000
Apexi VAFCII, K&N FIPK, Carbon Fiber Cooling Plate, PLM header, Berk HFC, Tanabe Medalion Touring exhaust, Swift Spec-R springs, Black Enkei RPF1's, 17x8/17x9, Dunlop Star Spec tires and black Work lugs.-220 tuned RWHP

2012 GM 370Z Touring/Sport w/Navi
K&N Typhoon intakes, Swift Spec-R springs, 20mm spacers all around

2010 CBP RDX
Hondata Reflashed
1TSXer is offline   Reply With Quote Quick reply to this message
Old 06-20-2009, 02:38 PM   #9 (permalink)
(9)
Moderator Emeritus
 
endlesswinterco's Avatar
 
Join Date: Apr 2008
Location: Charm City
My Ride: 2006 ABP & 2011 CBP Wagon
Posts: 2,360
endlesswinterco is on the distinguished road to high status recognition.endlesswinterco is on the distinguished road to high status recognition.endlesswinterco is on the distinguished road to high status recognition.endlesswinterco is on the distinguished road to high status recognition.endlesswinterco is on the distinguished road to high status recognition.endlesswinterco is on the distinguished road to high status recognition.endlesswinterco is on the distinguished road to high status recognition.
iTrader: (12)

Quote:
Originally Posted by 1TSXer View Post
I had this same problem and took mine to the dealer. They said the rack needs to be replaced. $1,600 Bucks is what it's going to cost me! Mine was leaking from the boot that connects to the rack and pinion box on the driver's side.
the boot isn't what is leaking, its a seal where the inner tie rod connects to the rack. the boot is just for protection from dust and dirt. Im pretty sure that 04tsx04 is going to try to replace just the seal. but im pretty sure the entire rack needs to be replaced.
endlesswinterco is offline   Reply With Quote Quick reply to this message
Old 06-20-2009, 03:00 PM   #10 (permalink)
Registered Member
 
EuroRspec's Avatar
 
Join Date: Aug 2008
Location: SF, CA
My Ride: s2000
Posts: 3,391
EuroRspec is either reputation whoring, or truly reaching the elite club.EuroRspec is either reputation whoring, or truly reaching the elite club.EuroRspec is either reputation whoring, or truly reaching the elite club.EuroRspec is either reputation whoring, or truly reaching the elite club.EuroRspec is either reputation whoring, or truly reaching the elite club.EuroRspec is either reputation whoring, or truly reaching the elite club.EuroRspec is either reputation whoring, or truly reaching the elite club.EuroRspec is either reputation whoring, or truly reaching the elite club.EuroRspec is either reputation whoring, or truly reaching the elite club.EuroRspec is either reputation whoring, or truly reaching the elite club.
iTrader: (3)

What's up with the 04s and steering racks. That should be Service Bulletin.
__________________

DIY: Suspension Install

http://www.tsxclub.com/forums/1st-ge...n-install.html
EuroRspec is offline   Reply With Quote Quick reply to this message
Old 04-07-2012, 11:35 PM   #11 (permalink)
Registered Member
 
Join Date: Feb 2012
Location: cen-tex/cen-cal
My Ride: tsx/04/cray
Posts: 6
wooosah is an unknown soldier, or on the road to either parallels.
iTrader: (0)

04's and a bunch of problems.. ughh smh
wooosah is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Acura TSX Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 07:18 AM.


Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
Contact Us - Acura TSX Forum - Archive - Privacy Statement - Top

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Optimization by vBSEO 3.3.2