Battery light came on (mild vent) - Acura TSX Forum
Home Forums Register Go Premium Garage Photo Gallery FAQ Auto Loans Members List vBGarage Mark Forums Read Auto EscrowInsurance


Go Back   Acura TSX Forum > Welcome > TSX Problems and Fixes > 1st Gen - Problems and Fixes

Welcome to TSXClub.com!
Welcome to TSXClub.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join TSXClub.com today!


Reply
 
LinkBack Thread Tools Display Modes
Old 11-26-2011, 11:01 PM   #1 (permalink)
Registered Member
 
Join Date: Oct 2011
My Ride: .
Posts: 28
DarkNinja75 is an unknown soldier, or on the road to either parallels.
iTrader: (0)

Battery light came on (mild vent)

Today the battery light came on. And it stays on. Looking at the repair list that the dealership did when they got the car, battery isn't on the list. So my first guess (and hope) is that the battery is going bad, especially since it's been colder than usual.

My second guess is that it's a bad alternator, which I'm hoping not. I didn't plan to buy a reliable car, only to spend $400 fixing it 6 weeks later.

I'm going to take the car to get the charging system and battery tested tomorrow.
DarkNinja75 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-27-2011, 12:35 AM   #2 (permalink)
Registered Member
 
Join Date: Jul 2011
My Ride: TSX/2004/Pearl White
Posts: 160
getafewlives is an unknown soldier, or on the road to either parallels.
iTrader: (0)

IMO, if I bought a car form a dealer, and paid a dealer price, I would expect them to fix this issue. My guess is the alternator.

But I tend to buy all my cars private because I think dealers charge too much and I don't trust the cheap ones.
__________________
http://i.imgur.com/wwtMO.jpg
Stock 2004 Acura TSX PWP 6 speed.
OEM Aero Kit
Lowered on Eibach sportlines
Drilled/slotted rotors
getafewlives is offline   Reply With Quote Quick reply to this message
Old 11-27-2011, 10:03 AM   #3 (permalink)
Registered Member
 
trqless's Avatar
 
Join Date: May 2011
Location: VA
My Ride: TSX/2004/Carbon Gray Pearl
Posts: 144
trqless is neutral and has a clean balanced record.
iTrader: (1)

Quote:
Originally Posted by getafewlives View Post
IMO, if I bought a car form a dealer, and paid a dealer price, I would expect them to fix this issue. My guess is the alternator.

But I tend to buy all my cars private because I think dealers charge too much and I don't trust the cheap ones.
Agreed. If you JUST bought this and have a 4 year warrantee, then shouldn't they be the one's covering this?

I also mainly buy my cars private party, with the exception of my tsx. Bought it in may 2011, 2004 with 92k miles, 6 speed w/ nav & tech, A spec lip kit, fogs, spoiler, and CGP. For 12k, which I thought was a great deal.
__________________
04 CGP TSX
A Spec Lip Kit
Color matched hood trim
3k HID Fogs (35w)
Top Fuel SRI
CT Engineering SSK & Blox 6 Speed Weighted Knob
BMW Shadowline Matte Black Vinyl on all chrome pieces
Awaiting install : Skunk2 Front Camber Kit(F&F V2 T1 coming soon)
trqless is offline   Reply With Quote Quick reply to this message
Old 11-27-2011, 05:07 PM   #4 (permalink)
Slow but turns
 
LeeMaster's Avatar
 
Join Date: Oct 2009
Location: United States
My Ride: 2004 Lancer Evolution RS
Posts: 2,961
LeeMaster is either technically knowledgeable, or well loved.LeeMaster is either technically knowledgeable, or well loved.LeeMaster is either technically knowledgeable, or well loved.LeeMaster is either technically knowledgeable, or well loved.LeeMaster is either technically knowledgeable, or well loved.LeeMaster is either technically knowledgeable, or well loved.
iTrader: (9)

Quote:
Originally Posted by DarkNinja75 View Post
I bought my 05 AT 6 weeks ago from a dealership so I could have a car I didn't have to worry about stuff breaking on. I even got a 4 year powertrain warranty. I had only owned a motorcycle for 2 years before, and it had been giving me an intermittent problem that no one could figure out (and still can't) for the past 4 months. I needed reliable transportation and figured the Acura would be it.

Today the battery light came on. And it stays on. Looking at the repair list that the dealership did when they got the car, battery isn't on the list. So my first guess (and hope) is that the battery is going bad, especially since it's been colder than usual.

My second guess is that it's a bad alternator, which I'm hoping not. I didn't plan to buy a reliable car, only to spend $400 fixing it 6 weeks later.

I'm going to take the car to get the charging system and battery tested tomorrow.

Annoyingly ironic how I bought a reliable car to get away from my motorcycle's electrical problems, yet now I'm getting them on the car.
If you had a 4 year powertrain warranty on your car, why are you worried about paying for the alternator??? You shouldnt have to pay for that if it was failing on you... unless your warranty specifically states that your Alternator is not warranted.

These Acura battery dies very quick, they dont last very long at all, i would say 6 years maybe 7 years at max! Replace the battery and you shouldnt have anything to worry about, go buy an aftermarket battery. DO NOT get it tested, those test are full of shit, the last time my battery was dieing on me I took it to the dealership to test my battery and they said my battery still have plenty of life left. My car would always die when I am parked after work and it eventually started to die while parked at stop lights.

No more issues ever since I bought a new battery, no more battery light on the dash..... always keep a receipt for ANY maintenance for your car..
LeeMaster is offline   Reply With Quote Quick reply to this message
Old 11-27-2011, 10:34 PM   #5 (permalink)
Speed Density
 
Join Date: Oct 2011
Location: California
My Ride: TSX/2005/Grey
Posts: 72
D-Jet is an unknown soldier, or on the road to either parallels.
iTrader: (0)

Battery light is coming on because it detects the alternator is not giving enough charge, or alternator has a bad diode, or battery is no good. Also check the battery cables if its loose or got high resistance.
D-Jet is offline   Reply With Quote Quick reply to this message
Old 11-27-2011, 11:41 PM   #6 (permalink)
Registered Member
 
Join Date: Oct 2011
My Ride: .
Posts: 28
DarkNinja75 is an unknown soldier, or on the road to either parallels.
iTrader: (0)

Reading through my warranty info (the agreement I signed) there is no mentioning of covering the alternator if it fails or any electrical component, although I also couldn't find anything specifically excluding it. Powertrain warranty, according to the info, covers things like internal engine components and transmission.

I think on paper, I'm on my own. But being 6 weeks from the purchase date, I would be surprised if the dealership decided not to cover it. I'll let you know how it turns out.
DarkNinja75 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Acura TSX Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 11:18 PM.


Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
Contact Us - Acura TSX Forum - Archive - Privacy Statement - Top

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Optimization by vBSEO 3.3.2