CEL code P0420 - Acura TSX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-16-2019, 11:22 PM Thread Starter
Registered Member
 
Join Date: Mar 2018
Posts: 2
 
iTrader: (0)
CEL code P0420

I was driving my car a couple of days ago when the Check Engine light started blinking . My car lost power but didn't stalled. I was near my house so I drove for a few miles instead of calling a tow truck . The next Day , I found it it was a misfire on cylinder 2 and needed the ignition coil replace (CODE P0302 ). I got replaced the ignition coil at my local shop and drove to work. Ten Miles Later , The CEL came back on. The car seems to be driving normally . I took it today to Autozone and They Got a new CODe : P0420 : Catalyst System Efficiency Below Threshold B1. Does this mean I need a new CAT ? or does anyone know any alternative fixes ?
duckfart is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Acura TSX Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
P2279 Code + RPM Issues when turning steering wheel rjkboyle 1st Gen - Problems and Fixes 0 11-20-2018 12:45 PM
radio/nav code entry problem daveinsc 2nd Gen - General Car Topics 6 10-24-2018 02:07 PM
New member! 2011 TSX CEL, VSA light, and limp mode. mrmicr 2nd Gen - Engine, ... 2 07-06-2018 03:30 AM
New PCB - 5 digit code provided for my 4 digit NAV temecal 1st Gen - Electronics, ... 5 05-19-2018 05:58 PM
Home Destination PIN code dsf3g 2nd Gen - Problems and Fixes 0 11-25-2017 10:32 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome