08 a/t engine mounts - Acura TSX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-01-2019, 04:10 PM Thread Starter
Registered Member
 
t0dam0nster's Avatar
 
Join Date: Sep 2014
Location: Ardmore, PA
Posts: 5
 
Send a message via Skype™ to t0dam0nster
iTrader: (0)
Unhappy 08 a/t engine mounts

Hey guys,
'08 TSX auto trans. I'm starting to get vibrations at idle. Being a mechanic, I'm 95% sure it's the engine mounts. Now here's my question:

What brand have you guys been happy with (other than OE)?

Did you do ALL the mounts?
Just engine mounts?
Just trans mounts?

I'm dreading doing any of them, but I know I'm going to have to before September ends (State Inspection expires then).

TIA
Adrian
t0dam0nster is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Acura TSX Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem figuring out why engine light is flashing Mel32843 1st Gen - Problems and Fixes 1 03-17-2019 08:59 PM
2006 Acura TSX Engine Ticking BecksBC3 1st Gen - Problems and Fixes 3 02-03-2019 09:05 AM
2008 TSX: engine no start, then start Edgeman 1st Gen - Problems and Fixes 1 11-26-2018 10:01 AM
Upgraded Motor Mounts? Vogenitz69 2nd Gen - Suspension, ... 0 12-27-2017 08:03 PM
DIY 6MT Transmission Mounts (3 pc) BarryMC 1st Gen - Suspension, ... 3 10-09-2017 12:04 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome