Has your AC failed? Report it here! - Page 15 - Acura TSX Forum
 3Likes
Reply
 
LinkBack Thread Tools Display Modes
post #211 of 218 (permalink) Old 06-27-2018, 08:45 AM
Registered Member
 
TSX_driver's Avatar
 
Join Date: Sep 2011
Location: SW Chicagoland
Posts: 37
 
iTrader: (0)
I have the compressor, condenser+reciever, and radiator installed on the car again. All new.

When I drained the oil from my old compressor to measure the quantity inside (turned out to be 1 oz), it came out looking clean, but with a small amount of sediment and debris. So now I am ordering a new expansion valve and evaporator. Not looking forward to being stuck under the dash

I don't know what to do about the hoses, I want to get the car ready and I fear I am wasting the desiccant element inside the receiver by opening the system every time I am removing an AC component.

Car: 2006 Acura TSX!!!!1
Driver: 1987 Chicago guy!!

206k miles June 2018
TSX_driver is offline  
Sponsored Links
Advertisement
 
post #212 of 218 (permalink) Old 06-29-2018, 05:31 PM
Registered Member
 
nitrolouie2142's Avatar
 
Join Date: Jun 2018
Posts: 1
 
iTrader: (0)
have a 2007, just bought it compressor clutch shot. installing a new one. no clue when it crapped out. but has 130,000 on the clock.
nitrolouie2142 is offline  
post #213 of 218 (permalink) Old 07-01-2018, 12:16 PM
Registered Member
 
mrgold35's Avatar
 
Join Date: Jul 2006
Location: ABQ, NM
Posts: 538
  
Garage
iTrader: (0)
So far, the $130 eBay compressor+clutch is working after +2 weeks after install. Cost me another $500 for labor+parts to install on top of the $290 I wasted at Acura when they replaced the O-ring that didn't work. It cost me a little under $1000 get get everything back to normal (it has been 95-103 in ABQ in June).

__________________
Son - 06 TSX 5AT w/ Navi, Carbon Gray w/ Quartz
08 RDX Tech, Moroccan Red Pearl w/ Taupe
11 MDX Adv/Ent, Palladium Metallic w/ Ebony
19 MDX sh-sh-awd Adv Fathom Blue Pearl w/ Graystone
mrgold35 is offline  
 
post #214 of 218 (permalink) Old 07-18-2018, 10:54 AM
Registered Member
 
Join Date: Mar 2017
Location: Bay Area
Posts: 40
 
iTrader: (2)
05 NHBP 6MT
163k Miles

Compressor Siezed

Replaced compressor and condenser with remanned units, now I can't get the a/c compressor clutch to engage
mathlabs is offline  
post #215 of 218 (permalink) Old 07-19-2018, 01:52 AM
Registered Member
 
Join Date: Mar 2017
Location: Las Vegas, NV
Posts: 8
 
iTrader: (0)
2008 6 speed with 89k it went out soon as i registered it at DMV out of the parking lot! lol mfer...paid $1000 with new OEM compressor and condensor and vacuumed system.

It has 109k now. knock on wood thats the only thing that went out. Ive only done regular oil changes and changed the plugs at 100k. I love this car!!

2008 Nighthawk black/ black 6 speed/w Navi. 109k miles

S.B. Reflash

to install:

CT icebox, 3 inch exhaust w/ Borla muticore muffler
s50saloon is offline  
post #216 of 218 (permalink) Old 12-26-2018, 08:08 AM
Registered Member
 
Join Date: Jan 2014
Posts: 3
 
iTrader: (0)
06 automatic with 126k miles. Compressor went out June 2018 at 120k. Compressor and condenser replaced with Honda parts by independent shop for $1,087. (The start of an avalanche: Rack & Pinion, starter and alternator now failed and replaced.)
Ret11 is offline  
post #217 of 218 (permalink) Old 12-26-2018, 12:47 PM
Registered Member
 
Join Date: Feb 2017
Posts: 34
 
iTrader: (0)
06 6speed, bought the car in february off craigslist ($6300) and didnt notice that the ac was out when i bought it with around 134k. figured i would drive around all summer without ac until the pulley on the ac compressor finally seized and my car was having a charging problem from the belt not spinning quick enough. It seized in the fall once the weather was decent enough to ride without ac. i sweated all summer without ac for no reason other than being cheap. replaced the compressor with oem reman by a honda specific shop for $600. been over a year and have 180k with no other issues.
Hinkmeister is offline  
post #218 of 218 (permalink) Old 01-12-2019, 12:10 PM
Registered Member
 
Join Date: Feb 2010
Posts: 1
 
iTrader: (0)
2005 with 144k compressor just blew, very difficult to turn. Up Until now no work had been done. Wishing they would have totaled it when it was in a wreck last year.
zawinnie is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Acura TSX Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome