Acura TSX Forum banner

cel

  1. Possible Check Engine Light VSA (!) new solution Please Help

    1st Gen - Problems and Fixes
    hi guys, Long story short I have a 04 TSX with 165,000km on it, and got the code P0341. I actually got the code the day after I bought the car used at 150,000km. Like many others on this forum, the CEL, VSA and (!) would turn on on morning/cold starts. VSA and (!) would go away, but the CEL...
  2. Bad cat

    1st Gen - Problems and Fixes
    Hi everyone, I had been strugling with my CEL for a while. I have P0420 code. I went to indy shop, they did diagnose upon doing proper checks on both sensors, and concluded that it is, as I suspected, bad cat. Now, with decent amount of certainty, I can say that cat is the problem and needs to...
  3. CEL was checked and gave me a P1035 again

    1st Gen - Problems and Fixes
    wassup peeps. i scanned my CEL awhile back and it gave me p1035 oxygen sensor heater bank 1. i had to go state ref so i borrowed my buddies piping and o2 and the CEL went away. i went back to my piping and my "malfunctioning o2" after passing. i ordered an o2 from ebay from primechoice auto...
  4. HELP!! Please... CEL P1157

    1st Gen - Problems and Fixes
    Hey guys I don't post on here much, still trying to learn my way around and don't get much time.. But I need some help. I have an '06 AT with DC headers/Injen CAI/APEXi exhaust. Emissions light came on a while back, throwing code P1157 "Manufacturer control fuel air metering." Called the...
  5. HELP!! Please... P1157

    South West
    Hey guys I don't post on here much, still trying to learn my way around and don't get much time.. But I need some help. I have an '06 AT with DC headers/Injen CAI/APEXi exhaust. Emissions light came on a while back, throwing code P1157 "Manufacturer control fuel air metering." Called the...
  6. Catalytic Converter / O2 Sensor Malfunction...Confused!

    1st Gen - Problems and Fixes
    I have a completely aftermarket exhaust system (see below) and I have been throwing the CEL code P0420 (Catalyst System Efficiency Below Threshold {Bank 1}). I bought an OBDII reader to clear this code (usually took a week or two to reappear) and after a while I got lazy and just left it on. I...
  7. Another check emissions problem :(

    1st Gen - Problems and Fixes
    Hi, I just installed my hps short ram intake, and with the crappy instructions. After I installed, I forgot to plug the air sensor thing in so I got the check emissions and check vsa. After reinstalling the air sensor, the check vsa went away but not the check emissions. Should I do the wait 3...
  8. CEL/VSA problem

    1st Gen - Problems and Fixes
    Ok so i've had my '04 tsx for almost 4 years now. I'm currently at 99xxx miles and just recently my cel has come on while I was driving and I noticed that the VSA turns off as well. My main concern with this problem is that I noticed the car starts to jerk as if it is going to stall while i'm...
Top