Acura TSX Forum banner
starter
1-7 of 7 Results
  1. 1st Gen - Problems and Fixes
    Hey guys, was switching the starter motor on my 05 tsx and when reassembly I noticed this tube. I think it's a vacuum tube but I'm not sure what it's supposed to be attached to. It appears to be cut or broken and there's dirt on the inside of the tube so I think it's been like that for a bit. It...
  2. 1st Gen - Problems and Fixes
    started about 4 days ago, it would crank a little when trying to start. tried to jump it and that didnt work. i got a free replacement battery the next day and that didnt fix it when installed. now its about 4 days later and now the car isnt cranking much. if its the first try it will turn...
  3. 1st Gen - Engine, ...
    Car is 04 6speed Manual I recently added a Skunk 2 Pro Series Intake Manifold, a Grams 72mm throttle body, a Skunk 2 composite fuel rail and DC shorty headers. These were in addition to pre existing mods, Random Technologies high flow Cat, K & N cold air intake, full Skunk 2 bolt on exhaust...
  4. 2nd Gen - Problems and Fixes
    *Noobie warning!* :ohsnap: I just got my 2009 Acura TSX (tech) and I love it except for when I cold start in in the morning. It goes "tick, tick, tick, start, and then SCREECH!" I've taken over to the Acura dealer twice now but it never recreates the noise. It's under warranty for a while...
  5. TSX Classifieds Archives
    Selling a starter that i just pulled from a 2004 tsx that just hit 80,000. It works great. The only reason im selling it is cuz i bought it for my car thinking that my starter broke, but it was only a disconnected ground wire so i put mine back in and no longer need this one. Asking 150$ local...
  6. 1st Gen - Problems and Fixes
    I have 120,000 miles on my 2004 TSX. Recently I posted asking for suggestions on tracking down a parasitic drain. I have been watching the car and battery very closely, and I have to agree with the Dealer, there is nothing drawing excessive amperage. But I am still having a "slow start"...
  7. 1st Gen - Problems and Fixes
    When i start the car it doesnt crank. When its in second click only the blue circles around the cluster glow and the check engine or srs or seatbelt light dont turn on. the battery isnt a problem cause i checked the voltage on it. So when i turn on the key no sound and the cluster circles stay...
1-7 of 7 Results
Top