Acura TSX Forum banner

vsa

  1. VSA system problems after oil change

    1st Gen - Problems and Fixes
    My father has a 2004 TSX and went in to have the oil changed at Jiffy Lube about two weeks ago. As he exited the bay door, the car went into limp mode. I was wondering if there is anything they could have done or unplugged while changing the oil and checking the air filter that could have...
  2. 06 VSA not working and now timing chain issue!

    1st Gen - Problems and Fixes
    Hi, New to the club, please forgive newbie mistakes! :smile2: I could really use some advise if anyone could assist! I have a 06, 6 speed, about 2 years ago in a bad storm my tires were spinning in a lot of rain and POP! The VSA light came on and traction control ceased working. Checked the...
  3. Check VSA light comes on intermintently

    2nd Gen - Problems and Fixes
    I have a 2012 Acura tsx 6 spd manual. Have 95,000 KM on it and it has recently started to stop accelerating/ bogging down while just cruising on the high or in tow. I haven't seem to have any problems while cruise control is on. In the mornings on my way to work the check VSA light has been...
  4. VSA, ABS and VSA Indicator light Illuminated

    1st Gen - Problems and Fixes
    So I started up my 2004 TSX yesterday and the VSA, ABS and the VSA triangle indicator light were all lit up solid and stayed on. I have a feeling this has to do with a speed sensor or something along those lines? Any help would be appreciated about what this means and what the fix could be! Thanks.
  5. ABS sensor replacement issues

    1st Gen - Problems and Fixes
    So I recently had my ABS / VSA / Triangle lights come on. I read the codes using the diy method I found on the forum, cleared the codes and reset the VSA neutral position. The lights would go out for a while then come right back. I had several different codes due to them never being cleared...
  6. abs vsa (!) issue in need of help PLEASEEEEE

    1st Gen - Electronics, ...
    Hi I recently hit a pothole where my car was damaged badly. I changed my upper and lower control arms my axel broke and was replaced my caliper bent and was replaced my rim was destroyed and replaced and I needed to buy a new abs sensor bc it wouldnt come out of the old spindle tht I replaced...
  7. abs vsa (!) issue in need of help PLEASEEEEE

    1st Gen - Suspension, ...
    Hi I recently hit a pothole where my car was damaged badly. I changed my upper and lower control arms my axel broke and was replaced my caliper bent and was replaced my rim was destroyed and replaced and I needed to buy a new abs sensor bc it wouldnt come out of the old spindle tht I replaced...
  8. Brakes are spongy, is it bc VSA ABS (!) are on???

    1st Gen - Suspension, ...
    Hey peeps, So I hit a pothole a few weeks ago and finally got all my parts in. I hit the hole so hard that my stock rim completly broke and was only left with the star held on with the lugs. The damage amounted to a bent control arm, broken lower ball joint, bent upper arm, broken axel, broken...
  9. Brake issue going on NEED ADVICE!!!

    1st Gen - Electronics, ...
    Hey peeps, So I hit a pothole a few weeks ago and finally got all my parts in. I hit the hole so hard that my stock rim completly broke and was only left with the star held on with the lugs. The damage amounted to a bent control arm, broken lower ball joint, bent upper arm, broken axel, broken...
  10. VSA and Check Engine light on post air filter change!

    1st Gen - Problems and Fixes
    Help!! I just changed my air filter in my 05 TSX, no problems up until now! I tried to drive my car after we changed the filter and both the check engine and VSA lights are on, my car is sputtering and won't accelerate past 20mph! The transmission is also difficult to move! My POOR BABY!!! I...
  11. TSX VSA lights starts blinking when i lock the car

    2nd Gen - General Car Topics
    Is it normal to have VSA lights starts blinking when I lock up my TSX?
  12. Another check emissions problem :(

    1st Gen - Problems and Fixes
    Hi, I just installed my hps short ram intake, and with the crappy instructions. After I installed, I forgot to plug the air sensor thing in so I got the check emissions and check vsa. After reinstalling the air sensor, the check vsa went away but not the check emissions. Should I do the wait 3...
  13. CEL/VSA problem

    1st Gen - Problems and Fixes
    Ok so i've had my '04 tsx for almost 4 years now. I'm currently at 99xxx miles and just recently my cel has come on while I was driving and I noticed that the VSA turns off as well. My main concern with this problem is that I noticed the car starts to jerk as if it is going to stall while i'm...
  14. Check engine light code P2138 Help!!

    1st Gen - Problems and Fixes
    i just went to a shop today and diagnois my car and they pulled out code P2138 APP sensor a/b incorrect voltage. does anyone know what this means or how to fix this problem? it is going to cost alot if i take it to the dealers.
  15. Another TPMS question....but different

    1st Gen - Wheels, ...
    Hello all, new to the forum.....but I have checked out all the existing TPMS threads to no avail. Here's my problem: I just bought an 07 TSX and live in upstate New York. It snows here, so I went for some winter tires. I've fitted Honda part number 42700SDBA91 steelies with 195 60 16...
Top