Acura TSX Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello!

Anyone have suggestions for my problem?


04 6mt in Canada currently at 230 000kms.

My idle will bounce and dip really low sometimes (oil light on for a second and often stall itself out) when the car is in neutral or just driving. I changed the battery and alternator recently. Spark plugs have less than 10k on them, oil level is always full and changed on time, new air filter, valve adjustment, premium gas etc..

I’m confused and frustrated with my idle bouncing up and down. Usually my foot not even on the gas pedal in neutral at a stop light.

I’ve looked into this for the past two years and haven’t found a solution. Things I’ve seen being recommended include:

App sensor change?
New motor mounts?
injector duty cycle?
fuel pump?
Wiring short?
Vacuum leaks? (Checked and found nothing im


Any help is greatly appreciated!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Any idea what factory spec is? I’ll check that out. Throttle body / maf cleaned and same issues 🙁
 

·
Registered
Joined
·
311 Posts
Now that I think about it, I don't think the throttle cable tension is the culprit, but it's an easy check. When you open the cover for the App Sensor, wiggle the throttle cable to see if it's loose. Factory specs say it shouldn't move more than 15-18 mm. There's a lock nut that you can use to adjust the cable tension if it is loose.

Without any codes, it's tough to pinpoint the root cause of the idling issue. Since you've already covered many of the low hanging fruit, I would try some other simple cheap things like cleaning the MAP and IAT sensors, pouring in a bottle of fuel system cleaner, and unplugging the battery followed by the idle relearn procedure.

If none of those help, check the fuel pressure to confirm if fuel pump and pressure are good. You can narrow it down your troubleshooting from there after the fuel pressure check.
 
1 - 4 of 4 Posts
Top