Acura TSX Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
The cold weather has started in Michigan... and only one side of my heat/AC controls is functioning properly. The drivers side does not blow heat when the temp is turned up - but the other side works perfect.

I got underneath the dash and removed the blower regulator - because that is what is NOT moving/opening the baffles when it should. I took it apart and tested it on the bench, everything works fine. I took off the power transister, took it apart and tested it - no problems there. I knew it wasn't the transister because the heat is blowing hot on the passenger side. I've tried everything I can think short of taking it to the dealer and having them destroy the car...

Has anyone had this problem or have any more ideas?!?

Thanks.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #2
Update for anyone else who has the same problem - After a little but more troubleshooting - I determined it had to be the blower regulator. I ordered one, replaced it and everything is fine.
 

·
Registered
Joined
·
1 Posts
07 TSX With the same problem

Hello everyone totally new here but need some help. I have a 2007 TSX with the same problem. The heat comes out of all vents EXCEPT the drivers door vent that one blows cold air no matter what temp I have it set at. Do you think it is the same problem as the 04 with the blower regulator?? Also where can I order one and if you have a part # that would be sweet. Thanks in advance.
 

·
The other white meat...
Joined
·
743 Posts
Sounds like a blend door problem. It is the flap/door that opens or closes depending on what setting you have it on. I'd check into that. Normally they work off vacuum but it might work electrically.

I'd say check into that.
 
1 - 8 of 8 Posts
Top