Acura TSX Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter #1
want to see if anyone went through this problem im unsure if its the clutch or its the trans. my 04 tsx started acting up I had to give it more rpm in order for it to drive, once it drove it shifted fine and everything but if I wanted to go faster the rpm would go higher than usual, its almost like when an automatic trans is slipping but I don't know if it could be the clutch any suggestions??
 

·
Registered
Joined
·
103 Posts
Discussion Starter #2
04 tsx 6 speed problem

want to see if anyone went through this problem im unsure if its the clutch or its the trans. my 04 tsx started acting up I had to give it more rpm in order for it to drive, once it drove it shifted fine and everything but if I wanted to go faster the rpm would go higher than usual, its almost like when an automatic trans is slipping but I don't know if it could be the clutch any suggestions??
 

·
Registered
Joined
·
377 Posts
In a manual trans, the gear ratios are fixed. If you depress the throttle and the RPM's seem to rise quicker than the car changes speed, more than likely the clutch is worn out. There should not be any "slip" whatsoever while the clutch is fully engaged.
 

·
What to put here...
Joined
·
1,050 Posts
Sounds like your clutch could be slipping, which would be tested by applying the handbrake fully, then trying to start in 2nd gear. If the rpm's go up but the car isn't moving, you're experiencing a slipping clutch.

Then, it's a matter of checking clutch pedal adjustment and the operation of the master/slave cylinders, checking for hydraulic leaks, and the clutch disc itself.

How many miles? City/highway?
 

·
Registered
Joined
·
103 Posts
Discussion Starter #5
that's wat im hoping for that its the clutch that's worn I bought the car supposedly they put a stage 4 clutch in it but as of now the car doesn't even want to move I could even have it in gear and fully let go of the clutch pedal and it wont even bogg out and shut off but thanks for the info
 

·
Registered
Joined
·
103 Posts
Discussion Starter #6
well I bought the car with 181,000 but they supposedly changed the clutch and put a stage 4 clutch in it but yea as of now it doesn't go anywhere when I give it gas, I could even have it in gear and take my foot completely off the clutch pedal it wont even bogg out and shutoff, I mostly do city and a bit of highway I haven't seen any leaks but I've seen some gunk by where the flywheel cover is. im hoping its just the clutch.
 
1 - 7 of 7 Posts
Top