Acura TSX Forum banner
1 - 10 of 10 Posts

·
Registered
Auto 04 TSX
Joined
·
7 Posts
Discussion Starter · #1 ·
I had a new battery put in and my radio isn't working anymore. I have the code and punched it in but it still isn't working. the screen on my radio is cracked so I can't see if it says anything. does anyone have any ides on what to do?
 

·
Registered
Joined
·
237 Posts
The code would have changed if the unit was ever replaced, are you sure it's original and that you have the right code?
You can probably check the original code with the dealer, they'll probably want see registration.

It may just be an issue of what buttons you need to push when, maybe you can find someone with a similar year TSX, who FOR SURE knows their code and is willing to disconnect their battery and walk you through the process on the phone step by step.

I actually have an intact non-nav radio unit removed from my car, I'll take a look today and see if I can easily connect 12V and power it up. If so, I'll post the detailed code entry process.
 

·
Registered
Auto 04 TSX
Joined
·
7 Posts
Discussion Starter · #3 ·
The code would have changed if the unit was ever replaced, are you sure it's original and that you have the right code?
You can probably check the original code with the dealer, they'll probably want see registration.

It may just be an issue of what buttons you need to push when, maybe you can find someone with a similar year TSX, who FOR SURE knows their code and is willing to disconnect their battery and walk you through the process on the phone step by step.

I actually have an intact non-nav radio unit removed from my car, I'll take a look today and see if I can easily connect 12V and power it up. If so, I'll post the detailed code entry process.
Thanks for the response. This has happened a couple of times in the past whenever I get a new battery, and I've never had issues before. the car is bone stock, as well as the radio. it's all original. if I can't figure it out, I think I'll bring it to the dealer
 

·
Registered
Joined
·
431 Posts
if I can't figure it out, I think I'll bring it to the dealer
Probably the course of action I'd take.

I have a second gen but the process has been the same for every Honda I've ever had. If you've done it before, you probably aren't missing anything. It's as simple as putting in the code when it prompts you; no need to hit enter or anything. My only assumption is that you're trying to input a code that isn't for the radio.
 

·
Registered
Auto 04 TSX
Joined
·
7 Posts
Discussion Starter · #5 ·
Probably the course of action I'd take.

I have a second gen but the process has been the same for every Honda I've ever had. If you've done it before, you probably aren't missing anything. It's as simple as putting in the code when it prompts you; no need to hit enter or anything. My only assumption is that you're trying to input a code that isn't for the radio.
the first time my radio stopped working (when I first got a new battery) i punched in the code, and it worked. this time, my radio is now cracked and i can't see anything on the screen. I just assumed I needed to enter the same code, but it hasnt worked still. I think I might bring it to the dealership
 

·
Registered
Joined
·
1 Posts
this issue happened to me if the battery is disconnected for long the batteries inside the radio lose power i left the vehicle on for a while and with the batter connected to the car this was able to charge the batteries in the radion and it began to work
 

·
Registered
Joined
·
74 Posts
look at this thread as well ... you don't need to replace the entire radio but is still cheap if so.


you may be experiencing the same problem.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top