Acura TSX Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter #1
My low beam driver's side headlight would not turn on this morning, so I flipped the switch off and back on and both low beam headlights lit up. On my way to work the driver's side went out. I'm assuming it's the ballast (not igniter) since the headlight did light up, but went out when driving. What do you guys think? It's not the bulb because I replaced both bulbs last week. I have noticed the driver's side bulb isn't as blue as the passenger side (6000K bulbs), maybe that was a sign the ballast was going out.
 

·
Approved Trade Vendor
Joined
·
183 Posts
My low beam driver's side headlight would not turn on this morning, so I flipped the switch off and back on and both low beam headlights lit up. On my way to work the driver's side went out. I'm assuming it's the ballast (not igniter) since the headlight did light up, but went out when driving. What do you guys think? It's not the bulb because I replaced both bulbs last week. I have noticed the driver's side bulb isn't as blue as the passenger side (6000K bulbs), maybe that was a sign the ballast was going out.
If the color is off on one side and you just replaced the bulbs. It sounds like the ballast is the issue

Nick C.
 

·
Registered
Joined
·
82 Posts
Discussion Starter #3
If the color is off on one side and you just replaced the bulbs. It sounds like the ballast is the issue

Nick C.
Thanks I was thinking that same thing. I haven't popped the hood to look but are the ballast on top or down close to the bumper. That same headlight was flickering this morn. Guess I need to get a new ballast. Should I just check ebay? Also, awhile back when I was replacing the driver's side low beam headlight bulb the ground wire came undown and I said "f it" and left it that way. Do you think this will lead to any probs?
 

·
Approved Trade Vendor
Joined
·
183 Posts
Thanks I was thinking that same thing. I haven't popped the hood to look but are the ballast on top or down close to the bumper. That same headlight was flickering this morn. Guess I need to get a new ballast. Should I just check ebay? Also, awhile back when I was replacing the driver's side low beam headlight bulb the ground wire came undown and I said "f it" and left it that way. Do you think this will lead to any probs?
Oh, well yeah! That's probably what is causing your HID to flicker. That ground wire needs to be secured on a non-painted surface.

I would fix that, and then give it another shot

Nick C.
 

·
Registered
Joined
·
82 Posts
Discussion Starter #5
Oh, well yeah! That's probably what is causing your HID to flicker. That ground wire needs to be secured on a non-painted surface.

I would fix that, and then give it another shot

Nick C.
No the driver's side has the flicker. The passenger side is where the ground came loose a few months back...I haven't had any probs out of that side (passenger). So Ebay is the way to go or maybe a junk yard?
 

·
Approved Trade Vendor
Joined
·
183 Posts
No the driver's side has the flicker. The passenger side is where the ground came loose a few months back...I haven't had any probs out of that side (passenger). So Ebay is the way to go or maybe a junk yard?
Fix that ground wire first, but then yes, probably a junk yard

Ebay might be riskier, at least you can see it in person at a junkyard

Nick C.
 

·
Registered
Joined
·
82 Posts
Discussion Starter #7
Ok will do...just purchased a used (52K miles) ballast off a guy on ebay...$100 shipped. Looks like I'll need to remove the headlight assembly to replace the ballast.
 

·
Registered
Joined
·
82 Posts
Discussion Starter #9
Bought a new/used ballast off of ebay and attempted the install last night but the ballast must have been off of a '06 or newer TSX because it was smaller and had a different connector. Sucked because pulling the bumper wasn't the quickest task. So now I'm returning that ballast and I have to find another one. Any suggestions? Hate to spend $200 on a new one.
 

·
Registered
Joined
·
10 Posts
Bought a new/used ballast off of ebay and attempted the install last night but the ballast must have been off of a '06 or newer TSX because it was smaller and had a different connector. Sucked because pulling the bumper wasn't the quickest task. So now I'm returning that ballast and I have to find another one. Any suggestions? Hate to spend $200 on a new one.
Did you ever find a solution?
 
1 - 11 of 11 Posts
Top