Acura TSX Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Recently bought a 07 tsx with a bad transmission. Replaced the tranny drove good for 2 weeks and yesterday the D on cluster started blinking. I checked trans for oil and marked good on dipstick, then today it started to only take reverse sometimes and when I put it into reverse the NEUTRAL light also lights up and stays on

PS: other than the car not taking reverse sometimes it drives good stillno hard shifting or late shifting


Any input on what you guys think it may be? Thanks for the help in advance
 

·
Registered
Joined
·
2 Posts
Recently bought a 07 tsx with a bad transmission. Replaced the tranny drove good for 2 weeks and yesterday the D on cluster started blinking. I checked trans for oil and marked good on dipstick, then today it started to only take reverse sometimes and when I put it into reverse the NEUTRAL light also lights up and stays on

PS: other than the car not taking reverse sometimes it drives good stillno hard shifting or late shifting


Any input on what you guys think it may be? Thanks for the help in advance
I noticed I had a blinking "D" light on the cluster and a month or so later my car threw a check engine code for the neutral safety switch. I swapped it out with a NAPA one and the blinking went away. Not sure if that's your problem but just a suggestion.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I noticed I had a blinking "D" light on the cluster and a month or so later my car threw a check engine code for the neutral safety switch. I swapped it out with a NAPA one and the blinking went away. Not sure if that's your problem but just a suggestion.
Yeah thats exactly what mine did I ran the codes and it was the neutral safety switch I replaced it and the blinkin "D" went away drove mint thanks for the reply bro
 
1 - 3 of 3 Posts
Top