Acura TSX Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
i'm new here so this may be an issue already covered but if anybody has an answer...
ive got an 09 with crappy satellite radio reception. even in perfectly wide open areas, i get "no signal". dealer says it's not their problem, Sirius says it's not their problem. Anybody have any solutions to this? thx
 

·
Registered
Joined
·
15 Posts
My 2010 TSX had terrible signal. I was blaming XM as I always had Sirius with no problems. I had the antenna replaced under warranty and it is quite a bit better, but still cuts out. I think there may also be a TSB out for this issue somewhere.
 

·
Registered
Joined
·
4 Posts
Some of the older posts seem to indicate that the most likely defective parts are the shark fin antenna and attached feeder cable. I'm having the same issue and currently collecting information so that I can switch out the parts.
 

·
Registered
Joined
·
72 Posts
i'm new here so this may be an issue already covered but if anybody has an answer...
ive got an 09 with crappy satellite radio reception. even in perfectly wide open areas, i get "no signal". dealer says it's not their problem, Sirius says it's not their problem. Anybody have any solutions to this? thx
I had the exact same problem when I bought my 2009. Dealer changed out the sharkfin antenna and that fixed my problem. Bad antenna sounds like your problem.
 

·
Registered
Joined
·
4 Posts
Again, my question is as follows:

Some of the older posts seem to indicate that the most likely defective parts are the shark fin antenna and attached feeder cable. I'm having the same issue and currently collecting information so that I can switch out the parts.

Thanks for any help that can be provided!

Joe - -
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top