Acura TSX Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
So somehow the people at the carwash, when they were cleaning the inside of the windshield, knocked out the wiring that connects to the back(or part of?) the rearview mirror. The wiring splits off into three parts and all three parts I believe plug into three different places. The only problem is - I don't know where these go! As a result of the unplugged wiring, my entire instrument panel is out (speedometer, gas gauge, etc), turn signals and all windows (including sunroof) do not work. If anyone can help me figure out what wire goes where, that would be greatly appreciated! It'll save me a 30 minute drive to my mechanic (it's ok, I live in jersey - we don't use turn signals much anyway! haha :laugh: ) I can provide pictures of this later if it helps any.
 

·
Un-Civil Engineer
Joined
·
2,205 Posts
Damn car wash people! I would seriously be speaking to a manager and have the car wash pay for the repairs.
 

·
iVTEC no koe
Joined
·
1,913 Posts
If your situation is this:

The 3 wires connecting to the 7-pin connector at the back of your rear-view mirror are disconnected from the connector/plug itself. To reconnect:

Leaving the connector plugged into the rear-view mirror, if you are looking at the plug from the front of your car (looking into the front windshield), the 3 wires go into the left side only. From left to right, the wires should be as follows:

1. Black/Yellow
2. Black (This is ground)
3. Black/White
 
1 - 3 of 3 Posts
Top