Acura TSX Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
hello everyone, i’m having a problem with my 2004 tsx it isn’t starting at all. when i put the key in all the accessory lights turn on but once i turn it everything turns off and there is no crank. i’ve changed out the alternator, the battery, the starter, the starter relay, and the ignition switch. still won’t start at all and i’m thinking there could be a problem with the interior fuse box. tested if there was any power going to the ignition switch and there was no power. i’d appreciate any help thank you.
 

· Registered
Joined
·
347 Posts
Check the battery ground where it connects to the vehicle: tight, clean, corrosion free.

There are also three braided metal ground straps between engine and frame. Facing the motor there are two on the left which are easily accessible and one one the right near the shifter links (MT). Make sure those are not frayed, broken, or corroded, and also check their connections. I'd disconnect and clean at least the ones you can get to. They're cheap, so replace them if they seem at all corroded. Mine are fine, but I live in SOCAL.
 

· Registered
Joined
·
6 Posts
The original ground wires is on the left side engine mount area, another at the transmission side connecting to the frame under the intake box, 3rd is the negative battery terminal and possibly more as merlinj79 explained up above.

It seems as if your not getting enough electrical current to start the car maybe.

Hope it fixes your problem.
 
1 - 5 of 5 Posts
Top