Acura TSX Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hello everyone!

2 questions

Could the ballast cause the bulbs color to not show correctly? i've tried 6, 8, AND 10000K and they all look pure white to me.

Now because of this problem I read that the ballast could be the culprit, so I went ahead and purchased the DDM Tuning Slim Ballasts, only to find that i should've done some more reading since the connector from the car to the ballast doesn't match.

I've read that you need to re-wire or splice the cables, but is there another way? i.e. an adaptor?

This problem is referring to the low beams btw.

thanks in advance for your help!
 

·
Registered
Joined
·
355 Posts
Don't expect them to be the right color.

They don't have quality control nor are they oem specific for any cars. There also was some dirt on DDM where all they did was relabel the bulbs as 6k, 8k, 10k when in fact it's all a single color.

You pay for what you get.

But to answer your question no, ballasts affect brightness not color.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
I just had an epiphany, and a painful one at that. I find it highly difficult for both ballasts to have the same problem at the same time. Although its also difficult to think that different bulbs from different vendors would all have the same problem. IDK, i'm just very frustrated at the moment, please your input is appreciated.


Edit: i posted this right as Tsxer04 posted his reply, thank you, I guess i'll be getting rid of the ddm kit since there's no need for them.
 
1 - 3 of 3 Posts
Top