Acura TSX Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey all I've been dealing with some problems with my 08 tsx transmission. First thing was my clutch went out and took some internal transmission parts with it. I replaced the clutch and did a major rebuild on the transmission. Any after I did all that it drove fine for a few 1,000 miles but all of the sudden it starts popping out of 6th gear(6th gear only). I can't figure what it is and I need some help. I've replaced the detent springs for the shift forks and that didn't help at all. I'm kind of at a loss right now.
 

·
Registered
Joined
·
95 Posts
If the car itself is pushing you out of 6th when you believe you did a proper rebuild and everything was good for 1k miles then i suspect something is moving towards the firewall more than its supposed to or its bent in the direction. Check the movement of the engine and the health of the mounts.

only other things i can think of is a bent cable or a bent shift selector itself on the trans.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
If the car itself is pushing you out of 6th when you believe you did a proper rebuild and everything was good for 1k miles then i suspect something is moving towards the firewall more than its supposed to or its bent in the direction. Check the movement of the engine and the health of the mounts.

only other things i can think of is a bent cable or a bent shift selector itself on the trans.
So it was actually good for almost 4,000 and if I put my hand in front of the shifter it stays in, like it only needs a tiny bit of pressure to stay in gear. So your thinking motor mounts? Could it be transmission mounts as well?
 

·
Registered
Joined
·
95 Posts
So it was actually good for almost 4,000 and if I put my hand in front of the shifter it stays in, like it only needs a tiny bit of pressure to stay in gear. So your thinking motor mounts? Could it be transmission mounts as well?
Could be either, I have a bad passenger mount on my tsx and when in high rpm in 2nd it can kick it out of gear if I jerk the car too much.
 

·
Registered
Joined
·
256 Posts
I had shifting issues due to bad motor/tranny mounts. The shop that did my clutch replaced them with after-market, which were fine for less than a year but then got sloppy again. I then replaced all of them with OEM mounts, been fine ever since.

Those rubber mounts pretty need replacing in any car much after 100K.
 
1 - 5 of 5 Posts
Top