Acura TSX Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey guys I was going to ask if I could get some of your guys input on a issue I’m having with my 08 tsx.

So I had my oem catalytic converter cut out a few weeks ago and they took along the A/F sensor and 02 sensor. I ordered a new cat from rock auto and got the sensors from eBay . I know I should have gotten oem or Denso but I saw a bunch of people were ordering these from eBay and said they work.

The issue I’m having is I can’t get rid of the cel light. When I disconnect the battery and put it back I see that the sensors are working and I get a reading using blue driver . But after logging some of my data I noticed the cel comes on when the A/F short term fuel trim jump’s randomly from normal range to almost 50% I don’t know what causes this

I just wanted to see if someone has any ideas before I order different sensors.
 

·
Registered
2008 auto TSX CGP
Joined
·
591 Posts
My 08 only has an 02 sensor, no A/F sensor on the cat. Why did they take the A/F sensor? That's in the engine bay.

What codes are you getting? That will tell you much more than a CEL. That's just an indicator. Let us know what the code(s) are.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
They took the a/f sensor because they cut it from the bottom of the exhaust Down pipe where the sensor mounts into .
Codes that I’m receiving

P1172 A/F SENSOR S1 CIRCUIT OUT OF RANGE HIGH

P2A00
O2 SENSOR CIRCUIT RANGE / PERFORMANCE BANK 1 SENSOR 1
 
1 - 3 of 3 Posts
Top