Acura TSX Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1,418 Posts
Discussion Starter #1
Hi, I just installed my hps short ram intake, and with the crappy instructions. After I installed, I forgot to plug the air sensor thing in so I got the check emissions and check vsa. After reinstalling the air sensor, the check vsa went away but not the check emissions. Should I do the wait 3 days thing?
 

·
Un-Civil Engineer
Joined
·
2,205 Posts
You might try resetting the light by pulling the negative battery cable, waiting a few minutes, then re-installing it. I think that will reset the ECU and the light.

Someone please correct me if I'm wrong.
 

·
USMC
Joined
·
142 Posts
You might try resetting the light by pulling the negative battery cable, waiting a few minutes, then re-installing it. I think that will reset the ECU and the light.

Someone please correct me if I'm wrong.
I dont like hating unless i have a better answer... BUT... resetting the codes by way of battery cable can damage the electronic circuits. If you dont have a code reader you can go to advance or autozone and they will reset the code for free. Plus if you disconnect the battery and dont have the radio code you will have to call acura to get it, and if you bough your car used you have to fax them you registration+insurance and the works... Personal Experience... and the codes in the manual/under hood/glove box never worked for me...
 

·
Un-Civil Engineer
Joined
·
2,205 Posts
I dont like hating unless i have a better answer... BUT... resetting the codes by way of battery cable can damage the electronic circuits. If you dont have a code reader you can go to advance or autozone and they will reset the code for free. Plus if you disconnect the battery and dont have the radio code you will have to call acura to get it, and if you bough your car used you have to fax them you registration+insurance and the works... Personal Experience... and the codes in the manual/under hood/glove box never worked for me...
Definitely good points made! :thumbsup:

I know some of the local Autozones here won't clear a code for you, just read it. Since he knows the issue, just getting the code wouldn't help. That's why I usually suggest the battery cable method.

If you can get a scanner, its the best method.
 

·
Registered
Joined
·
1,418 Posts
Discussion Starter #5
thanks, I'm gonna try the battery thing tomorrow if it's still on when I go to school
 

·
Registered
Joined
·
1,418 Posts
Discussion Starter #6
I tried disconnecting the battery, only left it off for a couple of seconds, and i already had the radio and nav codes from when my battery died, and voila! my light went off :)
 

·
Registered
Joined
·
17 Posts
Same light on mine reset via removing batt. Light came back. I have a weapon r from a SI. Will the ecu learn or will I have to remove the weapon r and get a diff brand or save for te hondata.
 

·
Registered
Joined
·
17 Posts
Foun out what it was. The breather line was in front of the air sensor. I plugged it up and put on a breather from the engine. Works like a charm and light went off on its own
 

·
, Admin, Marketplace
Joined
·
3,073 Posts
You might want to just swing by your local parts store just to see if that code is stored in there so you can clear it out before you have to do a emission test. Some times the code will still be there even if the light is off. I had it happen to me a coue of time when I was messing around with installing a header.
 
1 - 9 of 9 Posts
Top