Acura TSX Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
P2647 keeps coming and going and sometimes VSA light comes on with it, its for the oil pressure switch?

Oil level is fine, and car drives normally

Any ideas?
 

·
Slow but turns
Joined
·
2,961 Posts
i had that problem with mines during the cold winter as well, the only engine mod i had at the time was UR Pulley and Resonator removal, it just stopped doing that recently. how cold does it get from where you live?

ps
I never gotten my codes checked before because it kept going on and off, eventually when i decided to go get it scanned it just stopped on me...
 

·
Registered
Joined
·
59 Posts
Discussion Starter #7
it gets down to -30C sometimes during winter where i live, however most of my driving is highway (so not a whole lot of vtec) and i always use GC 0w30, so i don't know whats going on!
 

·
Slow but turns
Joined
·
2,961 Posts
it gets down to -30C sometimes during winter where i live, however most of my driving is highway (so not a whole lot of vtec) and i always use GC 0w30, so i don't know whats going on!
you are suppose to use 5w30 or 10w30.... 0w30 will definitely screw it up because the oil is probably frozen and therefore causes your engine to go crazy. depending on how cold it is right now, you may switch to either 5w30 or 10w30 and see if that fixes the issue.

0w30 = Oil cannot tolerate cold winter because 0w = summer/hot oil

hope this helps! :)
 

·
Registered
Joined
·
59 Posts
Discussion Starter #9
you are suppose to use 5w30 or 10w30.... 0w30 will definitely screw it up because the oil is probably frozen and therefore causes your engine to go crazy. depending on how cold it is right now, you may switch to either 5w30 or 10w30 and see if that fixes the issue.

0w30 = Oil cannot tolerate cold winter because 0w = summer/hot oil

hope this helps! :)
i hope you're joking bro,
i understand you're trying to help, however, what you just said was 100% wrong,

If anything, 0W30 is supposed to be better for winter, (lower grade before W letter = better flow on a colder start), thats oil 101,

0W > 5W > 10W
 

·
TSX of the Month Winner
Joined
·
1,037 Posts
you are suppose to use 5w30 or 10w30.... 0w30 will definitely screw it up because the oil is probably frozen and therefore causes your engine to go crazy. depending on how cold it is right now, you may switch to either 5w30 or 10w30 and see if that fixes the issue.

0w30 = Oil cannot tolerate cold winter because 0w = summer/hot oil

hope this helps! :)
That is incorrect...

I've been in the automotive business for a long time and you've got it backwards. 0w30 is a thinner oil which means its easier to warm up during colder temperatures. a 10w30 is a lot thicker at start up which is more beneficial to a car in the summer with hot weather.

Oil has a different freezing point compared to water.

For a stock tsx, I would personally recommend you stick to manufacturer specs and use 5w30.
 

·
Registered
Joined
·
59 Posts
Discussion Starter #14
checked all connections & checked the fuse, all are good!

but CEL intermittently keeps coming on and off randomly (sometimes with the "VSA" & "!" warning lights)

im out of ideas :(
 

·
Registered
Joined
·
69 Posts
From what I have seen with the k24 accords replacing the VTEC spool valve gasket/pressure switch takes care of it. In some cases I have had to replace the entire spool valve.
 

·
Registered
Joined
·
4 Posts
yupp, 06 tsx, 177k. this happened just this past wknd, took it to mech. he replaced oil pressure switch took it for a test drive and now it needs a solenoid for the vtec. almost 400 bucks. other than that this car has been very good to us.
 
1 - 16 of 16 Posts
Top