Acura TSX Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
The check charging system warning light pops up when I accelerate. I’ve changed the battery and it done good for a day or two but now is popping right back up. I’ve removed the positive cable then the negative cable while running and the car died in both scenarios. Could it be the alternator?
 

·
Registered
2008 auto TSX CGP
Joined
·
555 Posts
Hi TDG,

Since your alternator is what powers your car after a start, disconnecting the battery should keep it running if the alternator is working properly. So yeah it appears that your alternator is bad.

You could also verify by checking the battery voltage with the car running. It should read much higher than when the car is not started, indicating that the alternator is working properly.

By the way, removing battery cables on modern cars while running is not recommended as it can cause severe electrical issues if reconnected while the car is still running.
 

·
Registered
Joined
·
68 Posts
This has been a reoccurring issue with high mileage TSX's. If you're alternator is bad then replace it but if if the charging light appears and reappears as you drive and go's away then it's probably bad wiring in the positive battery harness. It will eventually kill your alternator and drain your batter again. I just replaced mine the other day. The harness is about $100. Not too difficult of a job but its time consuming.
 

·
Registered
Joined
·
20 Posts
Researching on YouTube and come to find out its the Bluetooth module like they say it drains the battery which i disconnect and several months its fine and it came back again, ive check all battery terminals and ive change the alternator and still FN came back on.. any idea?
 

·
Registered
Joined
·
91 Posts
Researching on YouTube and come to find out its the Bluetooth module like they say it drains the battery which i disconnect and several months its fine and it came back again, ive check all battery terminals and ive change the alternator and still FN came back on.. any idea?
You. I can pretty much confirm this. I've been dealing with this exact same issue to the point that if I was stuck in traffic. The car would want to die but it just power and restart the navigation system. My BT module is completely dead and I haven't had an issue since.
 
1 - 5 of 5 Posts
Top