Acura TSX Forum banner
1 - 3 of 3 Posts

·
, Admin, Marketplace
Joined
·
2,147,483,653 Posts
So one of the locals had all of the dash lights come on just as you did. But did not drive the car long enough to kill it. From what everyone has said it is the alternator going out. Another local had the same thing and it stopped for a little while like your but it came back and it was his alternator.

So with that being said I think it is your alternator going out. Sometimes they don't just go out completely. They show signs like what yours is doing, but it will eventually go all the way out. It could have checked good because it was working right at the time they checked it. But it's not anymore and it's killing your battery.

Just my opinion from what I have been told.
 

·
, Admin, Marketplace
Joined
·
2,147,483,653 Posts
Obert,

Thanks for the information, I had my suspicion it was the alternator, but the fact that resetting the battery fixed the problem gave me reservations. Because it is an aftermarket Autozone part, I think I will just swap it anyway.

Thanks,
Mark
Maybe disconnecting the battery just reset the lights. But they will probably just come back on. Make sure the battery gets recharged all the way to. And let us know if replacing the alternator takes care of the problem. It sounds like it should :)

Thanks
 

·
, Admin, Marketplace
Joined
·
2,147,483,653 Posts
So I replaced the alternator today ($290 from dealer) and let me just mention that it was not easy with the fans and AC lines in the way. But I have not seen the problem since I changed it out this afternoon. In the end only time will tell if the error comes back on when I start it. I will let everyone know how this came out.
Well at least you know you have a good oem alternator.

Did they check anything before the dealer replaced it ?
 
1 - 3 of 3 Posts
Top