Acura TSX Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
First I got the tighten fuel cap message, I tightened fuel cap and after driving a few miles the notification disappeared. I noticed my “Miles range” would jump from 350 to 309 after only driving 2 miles or so, I expected it to go back to normal after driving my car again but it didn’t. when I left for work the next day, I got the “check emissions system“ message. then when leaving work I noticed my miles jumped back from 298 to 309 and then when arriving home it said I had about 250 miles until empty. My drive to work is only 23 miles. The gas gauge however was not jumping, just the miles until empty message on my dash. I’m taking the car to the dealership tomorrow and they’re going to put a scanner into it and check what the problem is but I figured I’d ask on here first to maybe help alleviate some stress
 

·
Registered
Joined
·
521 Posts
I had that issue happen to me intermittently. I replaced the gas cap and it went away.

Sometimes you have to twist the cap a few clicks more but I think that is temporary as the cap is probably losing seal and is on its way out.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
I had that issue happen to me intermittently. I replaced the gas cap and it went away.

Sometimes you have to twist the cap a few clicks more but I think that is temporary as the cap is probably losing seal and is on its way out.
I think you’re right, when I was omw to work today the check emission system message was gone
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top