Acura TSX Forum banner

1 - 5 of 5 Posts

·
What to put here...
Joined
·
1,050 Posts
Discussion Starter #1
So I had a CEL come on yesterday immediately as I started the car in the morning. I had the code read by a friends' scan tool and it was the P0135 (OBD-II Trouble Code: P0135 Oxygen O2 Sensor Heater Circuit Malfunction (Bank1, Sensor1)) code.

The primary O2 sensor was replaced due to a similar, but not the same, DTC code about 5 years ago and has since been moved from the OEM header, to a DC header (a few times) to the new Japspeed header. I've been extremely careful not to bang or knock the sensor when swapping it over.

Anyhow, we cleared the code and I drove the car about 5-8 on/off cycles, a total of about 40 miles, since the code was cleared. It wasn't until today about 1/2 way to work (about 5 miles into a 12 mile drive) that the CEL came back on.

I haven't scanned this one yet but assume it's the same code.

Is the only solution to replace the primary O2 sensor (again)? If so, does anyone here truly recommend sticking with Denso, the OE manufacturer, or should I save some cash and go with an AC Delco or Standard brand for about 1/2 to 3/4 the price?

The one I replaced 5 years ago was OE (Denso) straight from a Honda dealer, so needless to say, 5 years on an O2 sensor seems like a pretty short life -- only about 50,000 miles!

Opinions?!
 

·
What to put here...
Joined
·
1,050 Posts
Discussion Starter #2
Light went off last night for about 5 minutes, then came back on, again! I'm assuming it's the same code as before.
New primary O2 sensor on order. Car is still fully driveable, so I think it's still in the proper mode (not limp mode or open-loop).
 

·
What to put here...
Joined
·
1,050 Posts
Discussion Starter #3
Not that ANYONE apparently cares (lol) but I replaced the O2 sensor with a Walker plug-n-play replacement one and cleared the code -- the CEL is gone. :)
 

·
Registered
Joined
·
99 Posts
I richer system, or a system leaking oil or fluids in the exhaust can kill o2 sensors quicker... just sayin :) glad its fixed XD

I had to comment.... +100 ppl came here to read you talking to yourself... come on ppl XD
 

·
What to put here...
Joined
·
1,050 Posts
Discussion Starter #5
I richer system, or a system leaking oil or fluids in the exhaust can kill o2 sensors quicker... just sayin :) glad its fixed XD

I had to comment.... +100 ppl came here to read you talking to yourself... come on ppl XD
I gotta say, this place is dying a bit (ok, a lot!). What's up w/ the lack of POSTERS and just an abundance of READERS lately?
 
1 - 5 of 5 Posts
Top