Acura TSX Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
Took My 04 tsx to get it checked cuz it was leaking oil mechanic assumed it was the oil sending unit replaced it, drove it
Then parked afew hours later I see it leaking again took it back in the shop and then they relized it was the a small crack near the the threads on oil pressure sending unit, so they said they cant deal with it and I gotta take it to a machine shop, anyway I'm kind of in an unsure position on what to do any suggestion would help please on what is the best affordable fix, I was reccommended JB weld but no idea yet, any suggestions?

Thanks
 

·
Registered
Joined
·
205 Posts
If they put the oil pressure sending unit in and its now leaking around the threads I would be rasing hell.
The OPSU threads are tapered. If they put it in too far it' possible they could have caused the crack. Just throwing this info out there. Not sure how bad the leak was before.

It's possible that JB weld may bandaid the problem. One thing is for sure here. That is a problem.
 

·
Premium Member
Joined
·
2,513 Posts
as grounded said ive seen JB weld do some pretty crazy shit lol. But how bad is the crack? Most likely the best fix is to drill out the hole past the crack, re tap the threads and than use an adapter to go from the bigger thread size to the sending unit. (This needs to be done in a machine shop)

But this means the motor most likely needs to come out, and most likely needs to be mostly disassembled because the oil path ages need to be flushed afterwards. GL man thats a rough one :/
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top