Acura TSX Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
Hi everyone,

I have an Acura TSX '05 (Canadian model, which comes with daytime running lights). My daytime running light (DRL) indicator is ON on my dashboard and actual DRL lights not working. When the high beams are selected, only the passenger side comes on. Both bulbs are OK and the fuses also are intact. This problem appeared during the holidays after having to boost the car with an outboard battery for several times. I think it is a problem with the DRL module but I can't find it.

Does someone know where it is located in the TSX?

Thanks for your help.
 

·
Registered
Joined
·
6 Posts
The DRL module is usually tucked behind the steering wheel. Looks like a grey square box, with a blue connector? I can't remember the exact colour but I fixed it in my older civic and TL. I have the same problem now on the tsx but my high beams won't even work. My passenger side low beam comes on and turns off after 20 seconds or so but if I flick the lights off then on it will work fine. Anyone have this issue before?
 

·
Registered
Joined
·
1 Posts
so did any of you guys find the DRL module. I removed the panel under the steering wheel and looked up and still couldn't find this DRL module.I looked on both sides of the steering wheel and still nothing? Any hints? I searched the web and this module is supposedly grey and rectangular but I can't find it.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top