Acura TSX Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
So the nav unit in my 07 started eating nav DVDs. Me being the idiot I am, I took it to a local shop to have it fixed. They popped it open, told me they couldn't get parts, and gave it back to me in a box. I'm assuming Alpine won't take it in to refurb at this point. I take full responsibility for screwing if up because I should have done more reading.

So now I'm looking for another. I've found one at a local salvage yard, but its from and 06. As far as I can tell, its the same part. Am I missing anything, or should I be good to go? The local dealership already told me they could get the unlock code for it, so it should be plug and play, right?

Thanks for the help!
 

·
WAT DO?
Joined
·
716 Posts
06-08 units are the same.

Alpine can repair your nav unit for 150$ I believe.. It's on a stickied thread somewhere, Contact alpine and you should be able to get an address to send it to.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #3 ·
Bought a replacement unit today and it powers up, but I will have to wait until tomorrow to get an unlock code. My local Acura dealership has lazy hours (but they are very helpful) and the ones on the west coast are refusing to help me over the phone....

If someone here works at a dealership and would like to help, I can pm you all of the info.


And for anyone who might need this info in the future, the 06 and 07 are the exact same part and reference number. It is plug and play, minus the unlock code which is turning out to be more of a pain then I thought it would.
 
1 - 3 of 3 Posts
Top