Acura TSX Forum banner

1 - 20 of 21 Posts

·
TSX of the Month Winner
Joined
·
5,350 Posts
Discussion Starter · #1 ·
Ok to make the story short. I have own my baby for 7 months... and engine light is on for almost 3 months already. Acura still can't fix it... They said they installed a monitor system on my car and needs me to drive it. Anyone know what that is?

The error code is EVAP system error... They have already tried replacing the EVAP canister, and also the gas cap. No luck...
 

·
, Moderator Emeritus
Joined
·
10,086 Posts
Tough one. Usually (almost always) it's that the gas cap isn't put on securely.
I know they replaced, it, but......is it DEFINITELY on securely?
This probably isn't it (because it's too simple, in this case), but still, I'd recommend that you MAKE SURE the gas cap is on securely (give it a couple of turns and make sure you hear those "clicks"), then see if the light doesn't go off.
BTW it might take a couple of days to go off, even if this is the answer. That's what they say anyway, although in my experience it goes off pretty quickly after you start driving it again.

Aside from that, I couldn't begin to come up with anything if your Acura guys couldn't.

But maybe someone else can......


P.S. Just so we know which light you're talking about: I assume it's the one just to the lower-right of the tachometer, sort of just outside the "4-o'clock" position?
 

·
, Administrator Emeritus
Joined
·
4,123 Posts
The dreadful CEL, perhaps one of the most frustrating problems with just about any Honda/Acura model. If one dealership cannot fix your problem, bring it to the next. You're entitled to do so as part of your warranty coverage. You won't be suprised to find the knowledge of one dealership can differ significantly from another. Look up your local areas' dealership and see if anyone else on forum communities has recommendation on which you should be visiting.
 

·
TSX of the Month Winner
Joined
·
5,350 Posts
Discussion Starter · #4 ·
larchmont said:
Tough one. Usually (almost always) it's that the gas cap isn't put on securely.
I know they replaced, it, but......is it DEFINITELY on securely?
This probably isn't it (because it's too simple, in this case), but still, I'd recommend that you MAKE SURE the gas cap is on securely (give it a couple of turns and make sure you hear those "clicks"), then see if the light doesn't go off.
BTW it might take a couple of days to go off, even if this is the answer. That's what they say anyway, although in my experience it goes off pretty quickly after you start driving it again.

Aside from that, I couldn't begin to come up with anything if your Acura guys couldn't.

But maybe someone else can......


P.S. Just so we know which light you're talking about: I assume it's the one just to the lower-right of the tachometer, sort of just outside the "4-o'clock" position?

The malfunction indicator light.... I am pretty sure it is not the gas cap b/c I tighten it like a lot of clicks 6 or 7...

It only happens when the weather is hot... when it is cold, the light will never come on. Only if I leave the car under the sun for about an hour, then light will come on for sure.....
 

·
TSX of the Month Winner
Joined
·
5,350 Posts
Discussion Starter · #5 ·
CL9 K24a said:
The dreadful CEL, perhaps one of the most frustrating problems with just about any Honda/Acura model. If one dealership cannot fix your problem, bring it to the next. You're entitled to do so as part of your warranty coverage. You won't be suprised to find the knowledge of one dealership can differ significantly from another. Look up your local areas' dealership and see if anyone else on forum communities has recommendation on which you should be visiting.
Hee... believe it or not... there are like 4 dealers locally... I am at the one that is considered the best already. One would lame enough to tell me that I overfill my gas tank, so it happens WTF??? And even told me if I don't give my car to them for service, they will not honor my warranty ROFL. 2nd one will simply blame on the driver... i.e. you race your car. Or it will just claim, come on, it is normal, no car is perfect.... I mean it is the engine light wtf?
 

·
yes, i am a bitch
Joined
·
2,502 Posts
SAZABI said:
The malfunction indicator light.... I am pretty sure it is not the gas cap b/c I tighten it like a lot of clicks 6 or 7...

It only happens when the weather is hot... when it is cold, the light will never come on. Only if I leave the car under the sun for about an hour, then light will come on for sure.....
humm...i had a problem some what close to this with my old ride's alarm..i had a clifford alarm installed and whenever i parked my ride under the sun for a long time, it will disalarm itself...it drove me crazy...it wasn't fix until i got the car rewired and as well a new alarm from clifford...
 

·
TSX of the Month Winner
Joined
·
5,350 Posts
Discussion Starter · #9 ·
Zigen said:
humm...i had a problem some what close to this with my old ride's alarm..i had a clifford alarm installed and whenever i parked my ride under the sun for a long time, it will disalarm itself...it drove me crazy...it wasn't fix until i got the car rewired and as well a new alarm from clifford...
poor me.. I am hoping it will be hot again...
next step will be Canadian Commercial Arbitration Centre...
 

·
, Administrator Emeritus
Joined
·
2,496 Posts
hmm, seems very odd.

Is the car completly stock? no cold air intakes or anything?

When did this problem start at how many miles?
 

·
TSX of the Month Winner
Joined
·
5,350 Posts
Discussion Starter · #11 ·
Ray said:
hmm, seems very odd.

Is the car completly stock? no cold air intakes or anything?

When did this problem start at how many miles?
The engine light started come on when it was bone stock. I think it started coming on at around 10000km. But I am suspecting that the problem is already there when I got the car. I got the car in November and the weather was not hot. The light only comes on when the day is hot.
 

·
, Administrator Emeritus
Joined
·
2,496 Posts
SAZABI said:
The engine light started come on when it was bone stock. I think it started coming on at around 10000km. But I am suspecting that the problem is already there when I got the car. I got the car in November and the weather was not hot. The light only comes on when the day is hot.
something is definatly wrong, does the car drive different at all with the light on? Does it lose power? bad gas mileage? or everything feels normal?
 

·
, Administrator Emeritus
Joined
·
4,123 Posts
I'd keep trying other dealerships ... Or ask AJ Racing in BC who is a fairly support Honda scene mod shop which Honda/Acura dealership is good in their books.
 

·
TSX of the Month Winner
Joined
·
5,350 Posts
Discussion Starter · #15 ·
CL9 K24a said:
I'd keep trying other dealerships ... Or ask AJ Racing in BC who is a fairly support Honda scene mod shop which Honda/Acura dealership is good in their books.
choice of dealership is very limited here....
I doubt AJ would help... I think it is better to deal with acura canada...
 

·
, Administrator Emeritus
Joined
·
2,496 Posts
CL9 K24a said:
I'd keep trying other dealerships ... Or ask AJ Racing in BC who is a fairly support Honda scene mod shop which Honda/Acura dealership is good in their books.
I agree keep trying till they find the problem :sprint:
 

·
TSX of the Month Winner
Joined
·
5,350 Posts
Discussion Starter · #17 ·
Ray said:
I agree keep trying till they find the problem :sprint:
hee... I really doubt they can.

My car only has the canister and gas cap replaced.

A guy from another forum said he has the same problem on his MDX. Already replace canister, gas cap, gas tank, a plastic thing near the neck of fill tank.. but still happening LOL
 

·
, Administrator Emeritus
Joined
·
4,123 Posts
How old is your car? I'm sure if it's within a reasonable period of purchase, you can ask for a new car. This law is fairly applicable and I'm sure Canada will have such a consumer backed rule somewhere.

In general on any Honda, when the CEL activates, your car goes into "safe mode" thus loading another fuel/ignition mapping. This setting is not ideal for constant road use but instead to be driven/directed to a dealership to have the problem addressed. Your vehicle performance will not perform at it's optimum specifications when the CEL is activated. And I wouldn't bring the car into WOT VTEC range either. There are clearly problems that need to be resolved.

If you feel the dealerships are letting you down, I would urge you to contact Honda/Acura Canada Customer Support/Relations as soon as possible. Driving under a prolonged CEL activated setting is not good for the car/engine's basic performance.
 

·
TSX of the Month Winner
Joined
·
5,350 Posts
Discussion Starter · #19 ·
CL9 K24a said:
How old is your car? I'm sure if it's within a reasonable period of purchase, you can ask for a new car. This law is fairly applicable and I'm sure Canada will have such a consumer backed rule somewhere.

In general on any Honda, when the CEL activates, your car goes into "safe mode" thus loading another fuel/ignition mapping. This setting is not ideal for constant road use but instead to be driven/directed to a dealership to have the problem addressed. Your vehicle performance will not perform at it's optimum specifications when the CEL is activated. And I wouldn't bring the car into WOT VTEC range either. There are clearly problems that need to be resolved.

If you feel the dealerships are letting you down, I would urge you to contact Honda/Acura Canada Customer Support/Relations as soon as possible. Driving under a prolonged CEL activated setting is not good for the car/engine's basic performance.

Thank you! Can you give me more info about this CEL thing? Like how does it hurt the car? I am gonna need some arguement to talk to acura Canada. Thanks for the info :ghost:
 

·
, Administrator Emeritus
Joined
·
4,123 Posts
Basic CEL warning/malfunction indication and unrecommended prolonged usage can be found in all owners' vehicle manual. It's a term not just Honda/Acura brought about that can be easily referred to as a crucial problem that needs resolution with minimal delays on any make/model.
 
1 - 20 of 21 Posts
Top