Acura TSX Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My wife has a 05 tsx, this morning, just randomly the car started to shift hard, the D on the dash was flashing. She immediately came home. I turned the car on, the D was flashing, I put the car in R and in D and it SHIFTED very hard. (GANG)

Any Ideas?? Did the tranny go out just like that? Can it be a sensor, or cable etc???

Please help....
 

·
Premium Member
Joined
·
2,460 Posts
I would diffinately take the car in to a transmission specialist or the dealer for this one. Hopefully your tranny isn't completely done. As stated, check the fluid level and have you ever had the fluid changed?
 

·
Registered
Joined
·
87 Posts
your tranny is probably done. mine revved for a little then slammed into gear and then slipped out of gear again down the driveway. found a tranny with 30k on it for 400 bucks and got at it that night =P
 

·
LED Addict
Joined
·
874 Posts
This may sound stupid, but go get an oil change. My car did that once and it was time for my oil change also so once i got thee oil changed, the light stopped flashing. So if i were you, i would get an oil change first if its time.
 

·
Registered
Joined
·
49 Posts
The D4 light flashing means the PCM detected a problem. Have the code(s) scanned. Most parts stores do this as a free service.

That will help identify the problem to start troubleshooting.
 

·
-
Joined
·
1,593 Posts
The D4 light flashing means the PCM detected a problem. Have the code(s) scanned. Most parts stores do this as a free service.

That will help identify the problem to start troubleshooting.

Bingo... The "D" light flashing or the CEL light on means that an error has occured & codes are set or stored.

Find out what the codes are. The codes will tell you what to do next. :)
 

·
Registered
Joined
·
2 Posts
Discussion Starter #9
I checked the tranny fluid... they fluid barely touched the stick!!! The car was in the dealer less then a month again for routine stuff, and the service guy said everything was fine. I check the tranny fluid and it was super low. I added 1 quart of tranny fluid, it brought the level back up, but the trouble still continues. I'm scared to drive the car to the parts store to check the codes!!
 

·
Premium Member
Joined
·
2,513 Posts
I checked the tranny fluid... they fluid barely touched the stick!!! The car was in the dealer less then a month again for routine stuff, and the service guy said everything was fine. I check the tranny fluid and it was super low. I added 1 quart of tranny fluid, it brought the level back up, but the trouble still continues. I'm scared to drive the car to the parts store to check the codes!!
codes will still be there even if you fixed the problem, they need to be cleared and then you have to drive the car for a full drive cycle to see if they come back. other wise it will take 40 no fault starts for it to go away
 
1 - 10 of 10 Posts
Top