Acura TSX Forum banner

1 - 12 of 12 Posts

·
, Regional Meet Leader, Hawaii
Joined
·
1,506 Posts
Discussion Starter #1
all right guys, so my left headlight just went off one day and i assumed that it was only a blown fuse... i changed it twice and it kept blowing... was it my ballast? coz a bad bulb wouldnt cause this right? correct me if im wrong...
 

·
Retired Tsx Owner
Joined
·
3,174 Posts
Gotta take off the headlight unit to inspect it. Probably a bad wires touching each other. (+ and -) wires kissing..
 

·
Alberto Acosta - 808TSXer
Joined
·
1,176 Posts
his right headlight works but left one doesn't, and his right fog light doesn't work but his...
or maybe os the other way around.. LOL
 

·
, Regional Meet Leader, Hawaii
Joined
·
1,506 Posts
Discussion Starter #7
Gotta take off the headlight unit to inspect it. Probably a bad wires touching each other. (+ and -) wires kissing..
Hmmm which wire though? The one that goes to the ballasts? Coz I tried putting new fuse but it blows everytime so im thinking its the ballasts.. And nope I didnt do any re-wiring.. Could it be just the bulb too? Hmmmmm
 

·
, Moderator, Performance
Joined
·
2,513 Posts
a bulb can cause this, if the resistance is to high on the filament it can cause a small enough short to pop a fuse, try swaping the bulbs out on that head light and see what happens
 

·
, Regional Meet Leader, Hawaii
Joined
·
1,506 Posts
Discussion Starter #10
thanks guys, ill try to do that... coz i remember im not using stock HID bulbs anymore.. i got the cheap 8000k ebay ones... i hope that fixes my problem :)
 

·
Registered
Joined
·
3 Posts
Im having the exact same issue 05 Acura TSX Driver Side Low Beam. Fuse keeps blowing. Haven't done any new wiring. Already switched bulbs from one to other sid. Both work fine. There is moisture in the headlight. HELP !!!! [email protected] or respond here please.Thanks.
 
1 - 12 of 12 Posts
Top