Acura TSX Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
This problem is on a 2012 TSX 4 cyl, 5sp auto, 147K miles.
The shift from 1st to 2nd is delayed. The car gets out of 1st, the rpm's increase, if I'm not careful, until the trans finally engages 2nd. Then it engages with a car shuddering hard shift engagement. It seems to happen most often after the car warms up.
I only have the hard shift between 1 and 2.The rest of the up shifting is normal. No problems with down shifts.
There will also occasionally be a shuddering like the trans is trying to figure out if it should be in gear or change to another, can't decide, so it vacillates between in gear or starting to shift then going back into gear. If I let off the throttle or give it more gas, it will settle down.
I've checked the trans fluid level and it is good. I do not know how old the fluid is and I've made an appointment with my local mechanic to do a flush tomorrow.
No check engine light. No other electronic indicators of problems.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
The tranny flush has been done with no change in how it shifts.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
I’m having this exact problem. Did you ever figure out the problem? Or a solution?
No I have not. It does shift better but I still get the delayed 1-2 shift once in a while.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
I only did the flush. You could tell that the fluid that came out had not been flushed in a very long time. It was an ugly brown color.
There are two pressure sensors I will replace in the near future to see if that will also help.
 

·
Registered
Joined
·
4 Posts
I’ve just ordered these two pressure switches and will be replacing them sometime next week when I get them. I will report back after I get them replaced.
28600-r90-004
28600-r94-004
Also plan on pulling the linear selenoid to clean the filter but I have to order the gasket so that will be if replacement of the switches don’t fix the problem.
 

·
Registered
Joined
·
4 Posts
I replaced both 2nd and 3rd pressure switch as well the transmission filter and still no change. I also took out the shift selenoid and tested them to be good so put them back. Both are around $800 so didn’t replace them. At a dead end so I guess drive until it falls apart.
 
1 - 8 of 8 Posts
Top