Acura TSX Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
hello everyone im new here so I hoped im posting in the right area. I have a 04 tsx recently i had to replace the ballast and both bulbs problem is I used ebay bulbs and ballast. Now I cant see crap!!! I'm think its the bulbs because when i replaced the ballast everything was fine. Anybody know of any good quality bulbs over than oem or should i stick to oem parts all the way around. Also i think my alignment is off is this adjustable.

Thanks in advance
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
8000k its like my cutoff doesnt exist anymore i. Just have a spread beam. It so dim i can even see my turn signals before i couldnt.
 

·
TSX of the Month Winner
Joined
·
1,748 Posts
check The Retrofit Source for quality bulbs.
 

·
Let me...help you!
Joined
·
1,335 Posts
I bought really expensive bulbs earlier this year. At first, I regreted them because I had the same problem as you...I couldn't see crap and there was no discernable cutoff.

I decided to recheck the bulbs. It turns out that there is a notch in the base to make sure that the bulb is put in correctly. I had not visually checked the alignment when I first put them in, so my bulbs weren't aligned correctly. Even if you don't align the notch, it is possible to mount the bulbs and not know there is a problem. However, I think it puts the bulbs 1-2 mm out of position, thus causing the issue.

When I re-did the bulbs, I visually looked at the bulb and made sure they were aligned (rather than just using touch/feel). Now my bulbs are super bright with a clear cut-off. The 1-2 mm difference makes a world of difference.
 
1 - 6 of 6 Posts
Top