Acura TSX Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
I was driving the other day when my indicator lamp turned on. I took it to Autozone today and got it checked out. I wrote down the one code that came up:

P2138 - TPS/Pedal Position Sensor/Switch D/E Voltage Correlation

The autozone guy said it is probably the TPS sensor going bad. Any idea how hard it is to replace this and if it is something that I want to tackle? I've done basics before...I/H/E and some suspension work. I'd say I am a 5 on a lvl of 10.

Any help is appreciated - thanks!
 

·
TSX of the Month Winner
Joined
·
1,037 Posts
You'll have to order a TPS Sensor from a Aftermarket company called Omni. Honda/Acura does not sell a TPS sensor seperate from the Throttle Body Assembly.

Its not that hard a job but when you remove your TB, you'll have to re-bleed your coolant system. Its definetly time consuming. What year is your car btw?
 

·
Registered
Joined
·
58 Posts
Discussion Starter #3
It's a 2004 Acura. Damn that sounds like quite a bit of work. So if I take it into Acura, I am going to guess they are going to charge me the entire throttle body assembly?

Looking here - http://www.acuraoemparts.com/delray/jsp/srchrslts2_oem.jsp?catcgry1=TSX&catcgry2=2004&catcgry3=4DR%20TSX&catcgry5=THROTTLE%20BODY%20(1)&pp=0&np=25

looks like the throttle body is over $500. Hm...any idea where they sell the omni sensors? Don't see any for the TSX at kingmotorsports.com
(http://www.kingmotorsports.com/category.aspx?cat=61)

Edit: Actually it says that it fits all K-series.
 

·
TSX of the Month Winner
Joined
·
1,037 Posts
I havent really looked into the Omni TPS for a TSX but I've heard good things about because I use to own a K Swap'd Civic. 165 is a good price if there is a guarantee that there is no problems with the TB.

It should be plug and play only thing you need really is a socket set, some pliers, and some Honda Coolant.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #6
damn it, they fixed it in august and said the wires were coming out of the plug, causing it to short. now 2 months later, it happened again, they are going to replace the TPS sensor for $359...
 

·
long-term build
Joined
·
2,761 Posts
damn it, they fixed it in august and said the wires were coming out of the plug, causing it to short. now 2 months later, it happened again, they are going to replace the TPS sensor for $359...
:police:
HIGHWAY ROBBERY

I just bought 4 TPMS sensors for less than $100 shipped!

all they do is screw into place.
you just need to take the tire off, unscrew the bad sensor,
screw in the good one, and put the tire back on.

done deal.

damn, get away from that dealership for your own good!
 

·
trespassing Jeep owner
Joined
·
2,731 Posts
:police:
HIGHWAY ROBBERY

I just bought 4 TPMS sensors for less than $100 shipped!

all they do is screw into place.
you just need to take the tire off, unscrew the bad sensor,
screw in the good one, and put the tire back on.

done deal.

damn, get away from that dealership for your own good!
Not TPMS sensors, man. TPS sensors. Throttle position. Part of the DBW system. Entirely different beast.
 

·
What to put here?
Joined
·
1,990 Posts
Lol, I was also thinking TPMS until I read further into the thread.:laugh:
 

·
still plays with cars
Joined
·
328 Posts
damn it, they fixed it in august and said the wires were coming out of the plug, causing it to short. now 2 months later, it happened again, they are going to replace the TPS sensor for $359...
Why isn't this an emissions warrantee issue? 8 years and 80,000 miles for emissions parts.
 

·
Registered
Joined
·
1 Posts
:police:
HIGHWAY ROBBERY

I just bought 4 TPMS sensors for less than $100 shipped!

all they do is screw into place.
you just need to take the tire off, unscrew the bad sensor,
screw in the good one, and put the tire back on.

done deal.

damn, get away from that dealership for your own good!
I jus changed my app sensor about a month ago. Check engine light came on this morning. Went to AutoZone and used the scanner and it states that the app sensor is the problem again. Codes P2122 2127 0113 are showing up also with P2138. What would be the cause of my problem
 
1 - 12 of 12 Posts
Top