Acura TSX Forum banner
1 - 3 of 3 Posts

·
Whaattss up?
Joined
·
149 Posts
Discussion Starter · #1 ·
Few weeks ago installed DEPO headlights with original ballasts and wiring but with new bulbs that it came with. Today first time light went off so I switched bulbs, it's not the bulb. Checked and replaced blown fuse, second fuse blew right away. I did research and some say it's the ballast. Wiring should have been fine since it worked for 2 weeks after install so it's not short circuit (don't think). Can someone confirm this please before I buy D2S aftermarket kit?

BTW I did went through carwash and light went off literally minute after. Coincidence?

Any input is appreciated it. I don't want to get pulled over with one working headlight.. Thank you
 

·
Registered
Joined
·
2 Posts
Few weeks ago installed DEPO headlights with original ballasts and wiring but with new bulbs that it came with. Today first time light went off so I switched bulbs, it's not the bulb. Checked and replaced blown fuse, second fuse blew right away. I did research and some say it's the ballast. Wiring should have been fine since it worked for 2 weeks after install so it's not short circuit (don't think). Can someone confirm this please before I buy D2S aftermarket kit?

BTW I did went through carwash and light went off literally minute after. Coincidence?

Any input is appreciated it. I don't want to get pulled over with one working headlight.. Thank you
Few weeks ago installed DEPO headlights with original ballasts and wiring but with new bulbs that it came with. Today first time light went off so I switched bulbs, it's not the bulb. Checked and replaced blown fuse, second fuse blew right away. I did research and some say it's the ballast. Wiring should have been fine since it worked for 2 weeks after install so it's not short circuit (don't think). Can someone confirm this please before I buy D2S aftermarket kit?

BTW I did went through carwash and light went off literally minute after. Coincidence?

Any input is appreciated it. I don't want to get pulled over with one working headlight.. Thank you
I'm in the same situation, I think it's the condensation, I'm gonna open up the back cover and dry it out with a hair dryer and the ballast and seal it up good like a light bulb and hope for the best, Ill give a update
 
1 - 3 of 3 Posts
Top