Acura TSX Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter #1
how it going fellow members, im getting this front squeak and its driving me crazy! it happens in low speed parking and when the steering wheel is turned(even while still)

im putting my car up on the lift tommorow and i just wanted to know some potential areas that can cause these symptoms.

Thanks for the input guys!
 

·
Registered
Joined
·
332 Posts
how it going fellow members, im getting this front squeak and its driving me crazy! it happens in low speed parking and when the steering wheel is turned(even while still)

im putting my car up on the lift tommorow and i just wanted to know some potential areas that can cause these symptoms.

Thanks for the input guys!
Either the ps pump or perhaps the rack and pinion. Squeeze the boots that connect to the tie rod to feel for fluid leaking in them. ALso google "tsb 10-025" that one applies to it. Going through the same right now other then the seal in my rack blew out.
 

·
Registered
Joined
·
65 Posts
Discussion Starter #3
Either the ps pump or perhaps the rack and pinion. Squeeze the boots that connect to the tie rod to feel for fluid leaking in them. ALso google "tsb 10-025" that one applies to it. Going through the same right now other then the seal in my rack blew out.
alright im going to check it out in the morning. ill repost with findings
 

·
Keeping it Clean
Joined
·
261 Posts
yea sounds like the ps pump. by any chance did the power sterering pump ever been replace with the new O-ring? and has been flush? thats what i did and it stopped it. never came back, which i 'm happy. it was driving me crazy!! anyways good luck
 

·
Registered
Joined
·
202 Posts
Yah bro get ur checked up had the same problem and just left it not knowing it was going to cause my PS rack to leak really bad. The noise got louder and I could barley even steer. The total to fix at dealer is 2100$ my car was out of warranty but I mentioned to them other factors as well and they were able to contact Acura corporate and they were able to cover 75 percent of the cost me paying da rest 25 good luck bro hope u don't have to go through what I had to lol

Sent from my cm_tenderloin using AutoGuide.Com Free App
 

·
Registered
Joined
·
65 Posts
Discussion Starter #6
Yah bro get ur checked up had the same problem and just left it not knowing it was going to cause my PS rack to leak really bad. The noise got louder and I could barley even steer. The total to fix at dealer is 2100$ my car was out of warranty but I mentioned to them other factors as well and they were able to contact Acura corporate and they were able to cover 75 percent of the cost me paying da rest 25 good luck bro hope u don't have to go through what I had to lol
that sounds like a hell of a mission! im gonna take apart the pump tonight. my rack seals were bad and the front stabilizer bar bushing was shot. swapped them and the noise was "faint" but still there. seems like the ring mentioned earlier might be what i should look into more. once again will repost with further findings!
 

·
Registered
Joined
·
32 Posts
Could be the o-ring issue in the power steering rack, OR it could be the upper control arm bushings. Mine were toast and it was metal on metal, creating a horrible squeaking sound when I turned my wheel slowly.
 
1 - 7 of 7 Posts
Top