Acura TSX Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter #1
Hi guys,
Here is my story. Last week i was trying to clean my engine bay, so I went to O'reilly to see if they have any thing to clean my engine bay. The guy that work there gave me the Purple Power and told me to spray it on my engine and let it sit there for 30-40 mins before spray it off with water.

I did what he told me and guess what now my engine bay is f--ed up, all the aluminum and metal parts in my engine bay are now etched and oxidized. Quickly, I looked at the instruction on the bottle and it says DO NOT let it sit and dry:eek:hsnap:. Obviously I was stupid enough to listen to him without looking at the instruction. So I grabbed the water hose, trying to hose off that damn Purple Power off of my engine bay but it was too late all my aluminum parts now look like crap.

But wait, its not done yet. After I rinsed my engine with water now I having knocking noises under the intake manifold, close to the starter. Its not really loud but you can hear it when you sit in the car, which I never heard that knocking before. And Iam sure it not the ticking noise from the fuel injector.

So do you guys have any ideas how to recover the finish or get rid off the etched/oxidized of the aluminum and what can cause that knocking sound?
I really appreciate any inputs from you guys. Have a nice day!
 

·
Registered
Joined
·
326 Posts
Not sure how to help your aluminum parts but I would think the knocking sound could possibly be from getting water down into the sparkplugs. You need to pull each one out and try to blow all the water out. Hopefully that will help you out some.
 

·
, Regional Meet Leader, Toronto
Joined
·
782 Posts
this is why im afraid to spray anything on anything to do with my engine anymore.
my PSpulley seemed to **** up after a friend sprayed belt dressing on my belt.
 

·
Registered
Joined
·
56 Posts
Discussion Starter #5
Thanks for the inputs guys.
@wareagle19o9 - I did check my sparkplugs. As a matter of fact I just replaced my serpentine belt, sprakplugs and tranny fluid (I have a 6sp) yesterday but that knocking sound is still there.

@Lexx - tsx's belt is supposed to run dry, it doesn't need belt dressing like the old cars as far as I know. If you haven't replaced your belt, I think you should try to replace it and see if it helps.
Im thinking taking my car to the shop (this shop only does import cars so I think they know what theyr doing) and have them do the valves adjustment (Im at 88k miles) to see if that knocking sound will go away or not. What do you guys think?
 

·
, Chief SuperModerator, Info Center / Car Care & D
Joined
·
5,036 Posts
Hmm, I don't have an answer to your problems, but I do have advice. Next time, use car wash soap, dip a microfiber towel in there and wipe away. For hard stains, a window cleaner is good enough to remove them. It might take a bit of scrubbing, but I think it's better than spray degreaser and hose down the engine bay. After that, you can dress up the hose and trim with Mother's Back to Black or 303 Aerospace Protectant.

This method works just as well. It might take a lot longer than using degreaser and hosing it down, but it's fool proof.
 

·
Registered
Joined
·
1 Posts
I had the same problem on my 6spd tsx and my knocking was from my ac compressor...hope that helps anyone who had this similar problem as I couldn't find any info on it and had to diagnose the sound and figure it out myself...
 
1 - 7 of 7 Posts
About this Discussion
6 Replies
6 Participants
Tsx1987
Acura TSX Forum
TSX Club is the perfect forum for Acura TSX fans and Owners, where you can discuss concerns about reliability or how to upgrade your TSX with mods and accessories.
Full Forum Listing
Top