Acura TSX Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi, i was driving and when i exited the freeway and i accelerated all of a sudden i had an instant drop of power, my engine light was flashing on the left side of the dash, and in the area where my odometer is the Check Emissions Sensor came one. my car is idling rough and is going insanely slow. from a full stop it takes almost a full minute to cross an intersection. When the RPM's get to 3000 the car really stutters and shakes rough. If i let off of the gas pedal it will shift gears and continue on in the same slow manor with an insanely slow acceleration. Car can't accelerate past 40mph.

Has this happened to anyone else and any advice or tips on what may be the problem?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
yes it was flashing the check emissions sensor. but it also had a dramatic drop in performance. i could barely get the car to move forward and i was flooring it. when the rpm's got to 3000 the car would stutter like it wanted to turn off but once i let off of the gas it would shift gears and continue to slowly accelerate in the same manor as it was
 

·
-
Joined
·
1,586 Posts
1st up, stop driving the car and don't start the engine until you figure out what is wrong.

Then check the engine oil and coolant levels and quality.

Then get the codes read.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
ok. i just had the oil changed at Mineke 1 week ago. they also did a flush as the oil was very dirty. Car was actually running better. i won't start the engine in the meantime. how do i get the codes read?
 

·
, Chief SuperModerator, Regional (United States)
Joined
·
1,204 Posts
Your car is probably in "limp" mode, in which it won't allow you to accelerate past a certain speed/rpm in order to preserve the engine. To get your codes read, take it to a shop or buy a OBD-II scanner from your local automotive shop, and plug it into the OBD-II port located underneath the steering wheel to the left, near the hood release. It'll tell you what fault codes your car is throwing which would help guide you in troubleshooting the problem.
 

·
Registered
Joined
·
550 Posts
the computer senses an issue and puts car in limp mode.

it could be something simple or major........ the codes will tell alot.
 

·
Registered
Joined
·
1 Posts
Hi, i was driving and when i exited the freeway and i accelerated all of a sudden i had an instant drop of power, my engine light was flashing on the left side of the dash, and in the area where my odometer is the Check Emissions Sensor came one. my car is idling rough and is going insanely slow. from a full stop it takes almost a full minute to cross an intersection. When the RPM's get to 3000 the car really stutters and shakes rough. If i let off of the gas pedal it will shift gears and continue on in the same slow manor with an insanely slow acceleration. Car can't accelerate past 40mph.

Has this happened to anyone else and any advice or tips on what may be the problem?
 

·
Registered
Joined
·
2 Posts
Your car is probably in "limp" mode, in which it won't allow you to accelerate past a certain speed/rpm in order to preserve the engine. To get your codes read, take it to a shop or buy a OBD-II scanner from your local automotive shop, and plug it into the OBD-II port located underneath the steering wheel to the left, near the hood release. It'll tell you what fault codes your car is throwing which would help guide you in troubleshooting the problem.
I did that’s and my 2009 telling me check cylinder 3 misfire change spark plug same thing change coil same thing only thing my car ran hot and I just did the heads water pump and the whole coolant system please help me fix my car I don’t know what I’m doing
 
1 - 10 of 10 Posts
Top