Acura TSX Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter · #1 ·
TSXClub,

So lately my 04 TSX has been pulling sluggish and i think it may be due to the cat. The car has 110k right now w/ stock exhaust but I don't have any codes. The 04 stock cat is pretty restrictive from what I've been reading and want to replace it with a cat that has ~300 cells per sq in. I've looked at the RT converter but its a little too pricey for me. I came across MBS race converters which are rated at 100 cpsi and was wondering if anyone had a chance to try them out? I've searched the forum but couldn't find anything.

MBS 4" 100 cell (CPSI) High-Flow Race Converter

I want to get headers soon so this may help anyways (don't like the idea of the smell of test pipes). If no one tried this, I might just get it and have the shop weld it onto a test pipe.


edit: They have 200 and 300 cpsi.
 

·
Premium Member
Joined
·
2,513 Posts
TSXClub,

So lately my 04 TSX has been pulling sluggish and i think it may be due to the cat. The car has 110k right now w/ stock exhaust but I don't have any codes. The 04 stock cat is pretty restrictive from what I've been reading and want to replace it with a cat that has ~300 cells per sq in. I've looked at the RT converter but its a little too pricey for me. I came across MBS race converters which are rated at 100 cpsi and was wondering if anyone had a chance to try them out? I've searched the forum but couldn't find anything.

MBS 4" 100 cell (CPSI) High-Flow Race Converter

I want to get headers soon so this may help anyways (don't like the idea of the smell of test pipes). If no one tried this, I might just get it and have the shop weld it onto a test pipe.


edit: They have 200 and 300 cpsi.
There are many reasons the car could be sluggish. I doubt its the cat (its possible but I doubt it).

When were your plugs changed? air filter?

Could be a slightly clogged injector, could be a sensor starting to go bad but not bad enough to through a code yet.
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #3 ·
There are many reasons the car could be sluggish. I doubt its the cat (its possible but I doubt it).

When were your plugs changed? air filter?

Could be a slightly clogged injector, could be a sensor starting to go bad but not bad enough to through a code yet.
Plugs and filter changed about 10k ago. Good idea on the injectors, ill check them this weekend, not sure if the previous owner changed them. Got the car at 85k.

I might just get the 300 cpsi from MBS and will post results here.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top