Acura TSX Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
I looked around but I couldn't find anything about this particular issue.

I have an 05 TSX MT NAV and as of the other day when I put a disc into the CD player, it tries to read it for a bit then just flashes "error". Everything else works just fine, and the day before this happened the CD player was working just fine as well.

Does anyone know if there is a way to "reset" the CD player or anything like that? Or should I just pull the BATT for a while? Is this a common problem?

Thanks in advance for any help you can give me.
 

·
Registered
Joined
·
15 Posts
Had the same problem. Actually acura just put out a bulletin on it last week.

I solved it by opening up the nav dvd player in the trunk and cleaning the lens with alcohol and a qtip

Here is another reference to it:
http://www.tsxclub.com/forums/1st-gen-problems-fixes/33677-navigation-dvd-disc-reading-error.html

Alpine wanted $358 flat rate to fix it. No thanks, ill clean the lens myself lol

I found a thread somewhere about how to open it up, but it is pretty straight forward. Only three screws holding the top lid of the dvd player on.

You can also try a disc cleaner like 5 times over and over and that may work
 

·
Registered
Joined
·
15 Posts
Had the same problem. Actually acura just put out a bulletin on it last week.

I solved it by opening up the nav dvd player in the trunk and cleaning the lens with alcohol and a qtip

Here is another reference to it:
http://www.tsxclub.com/forums/1st-gen-problems-fixes/33677-navigation-dvd-disc-reading-error.html

Alpine wanted $358 flat rate to fix it. No thanks, ill clean the lens myself lol

Here is some instructions to fix it:
http://tl.*********.com/forums/showthread.php?t=873489

You can also try a disc cleaner like 5 times over and over and that may work
 
1 - 5 of 5 Posts
Top