Acura TSX Forum banner

1 - 10 of 10 Posts

·
owned ur ass
Joined
·
200 Posts
Discussion Starter · #1 ·
i just got the eibach prokit installed and now i hear a clunking noise whenever going over bumps. Its mostly from the rears but sometimes in the front too. Is something on the strut loose? I just tightened the strut tower bolts today and it helped a little, but its still there. Let me know what you guys think.
 

·
, Administrator Emeritus
Joined
·
4,123 Posts
Progressive springs generally will make noises, don't forget you're now running a higher rated spring rating.
 

·
owned ur ass
Joined
·
200 Posts
Discussion Starter · #3 ·
i see, so this is normal then... if i get a set of koni adjustable, or some other respectable brand of struts, would this fix the problem at all?
 

·
, Administrator Emeritus
Joined
·
4,123 Posts
Not really, the more harder the setup, the more sounds/noises you're gonna be hearing. Comfort/luxury isn't exactly something that goes hand in hand with increasing vehicle handling dynamics.
 

·
Registered
Joined
·
1,621 Posts
oh well ... i dont have such noise with my prokit .. ~~ it's quite as stock .. :) ~
i think the quilaty of the installation really matter .. ~~
but is there any aftermarket shocks except Koni ?? ~~ just wondering
 

·
Registered
Joined
·
1,621 Posts
no KYB in this point i believe .. ~~ :rolleyes:
 

·
owned ur ass
Joined
·
200 Posts
Discussion Starter · #9 ·
damn something is really messed up then on mine. I let Dzuy and TSXon19s ride in my car, and they had no idea what it was, they sure did notice it. I dont have the money to take it to the shop right now to get it checked out. Im kinda stuck, dont know what to do....
 

·
owned ur ass
Joined
·
200 Posts
Discussion Starter · #10 ·
well i tightened up the rear sway bar a little bit, didnt even see that you could use an allen key in the bolt to hold it in place, and it seemed to pretty much fix the problem. There were a few other bolts a little loose so i just went around and tightened every bolt and then wuhlah! problem fixed!
 
1 - 10 of 10 Posts
Top