Acura TSX Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hello guys, I'm new to this by the way so sorry if its in the wrong section.. Anyways I just bought a 06 tsx and it's modded. Has many aftermarket parts. And I'm kinda concern that the ex driver drove it a little to hard. It has the check engine light on, and it said "check emession system"

It has aftermarket headers, it has a hondata reflash, and a cold air intake. I just change the oil and filter and spark plug to a racing one and synthetic Mobil 1 oil. Reason why is because there is this noise when I start the car that sounds like two metals pieces scraping each other reall fast and loud. It's only on cold starts for the first 3 or 4 seconds of the car starting. If I turn it off and on it won't do it. I have to let the car sit an hour or so.

I asked the previous owner and he said some bs about that he fixed the timing belt to a racing one and that's why it does that noise that I shouldn't worry about it. -_- sounds like bs to me, plus we didnt leave on good terms so I'm worried he just want my car to **** up. Lol anyways, any body have any suggestion on what the problem might be and if I should fix this. Maybe he was right and I just didnt know that the noise is normal. Idk, it doesn't sound normal. HELPP!!!

Also!!! "Check emession system" should I be worried about that??
 

·
Premium Member
Joined
·
857 Posts
Any check engine light is never good. Go get the code read and post it up or check online. Also, the 2006+ doesn't have the "hondata reflash" from what I remember. They have Flashpro which is quite pricey, so if your car has flashpro, then that's a plus. As for metal scrapping, that's never good. I've never heard of a "racing timing belt" for our cars... especially since our cars have timing chains... and rarely need to be changed or upgraded. Maybe check the tensioner.

Looks like a lot of BS the guy said to you. Did you not have the dealer or a mechanic check it out before you bought it? It's always a good idea to do that...
 

·
Registered
Joined
·
3,428 Posts
It is BS. You don't have a timing belt, one. Two, the sound you are hearing is associated with your Timing Chain. I can guarantee 100% that the sound you are hearing is the timing chain tensioner. It will sound like a rattle and only happens on cold starts about once a day. It has to do with it not retaining it's oil pressure till the car is started. It can eventually fail and hurt your engine. I would replace it immediately.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
Yeah I think your right bro, plus this was a little Asian kid who had to sell the car because he couldn't finish paying it off. He did so much stuff to the engine that I don't know half of the stuff in it. I just know the basic CAI, headers, reflash, exhausts, he has a spacer between the CAI and the engine. If this noise is coming from the timing chain, how much is it to repair, and what could happen??
 

·
VP of Infinite Infinity
Joined
·
1,791 Posts

·
Registered
Joined
·
124 Posts
Any check engine light is never good. Go get the code read and post it up or check online. Also, the 2006+ doesn't have the "hondata reflash" from what I remember. They have Flashpro which is quite pricey, so if your car has flashpro, then that's a plus. As for metal scrapping, that's never good. I've never heard of a "racing timing belt" for our cars... especially since our cars have timing chains... and rarely need to be changed or upgraded. Maybe check the tensioner.

Looks like a lot of BS the guy said to you. Did you not have the dealer or a mechanic check it out before you bought it? It's always a good idea to do that...
'06 does have reflash - got it on mine.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top