Acura TSX Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I'm getting code p0172 check engine light. I've changed injectors, maf sensor, valve adjustment,o2 sensor up top,and the code keeps popping up. Any suggestions out there or anyone experienced the same issue and found the cause without spending a gazillion on parts for no reason?
 

·
Registered
Joined
·
521 Posts
Check your air cleaner to see if it needs changing. If too dirty, you won't get enough air making your car run richer.

You can also try to reset your error codes. You may just need a reset.
 

·
Registered
Joined
·
8 Posts
I'm getting code p0172 check engine light. I've changed injectors, maf sensor, valve adjustment,o2 sensor up top,and the code keeps popping up. Any suggestions out there or anyone experienced the same issue and found the cause without spending a gazillion on parts for no reason?
Mine is in shop right now apparently the mechanic stated in has stretched timing chain off 2 teeth. he also stated he will go in and lean the fuel trims on it. You can see my post earlier in here about the pain in the butt. Oh yes by the way we spent around 4,000 in parts and labor chasing that code. I will let you know if it is repaired by next week.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Mine is in shop right now apparently the mechanic stated in has stretched timing chain off 2 teeth. he also stated he will go in and lean the fuel trims on it. You can see my post earlier in here about the pain in the butt. Oh yes by the way we spent around 4,000 in parts and labor chasing that code. I will let you know if it is repaired by next week.
Mine is in shop right now apparently the mechanic stated in has stretched timing chain off 2 teeth. he also stated he will go in and lean the fuel trims on it. You can see my post earlier in here about the pain in the butt. Oh yes by the way we spent around 4,000 in parts and labor chasing that code. I will let you know if it is repaired by next week.
Thanks...I had a mechanic state that it could be the problem as well...but I had a valve adjustment done and it took care of VERY LOUD ticking sound coming from the engine which was what made him mention timing chain in the 1st place. I'm hearing that exhuast leaks can throw that code as well, I'm definitely smelling fumes every time I start the car
 

·
Registered
Joined
·
8 Posts
Thanks...I had a mechanic state that it could be the problem as well...but I had a valve adjustment done and it took care of VERY LOUD ticking sound coming from the engine which was what made him mention timing chain in the 1st place. I'm hearing that exhuast leaks can throw that code as well, I'm definitely smelling fumes every time I start the car
We had valves adjusted 4 plugs 4 coils new cats new 02 both map fuel pressure 4 injectors car has got 126,000 miles on it. It rattled at start up (common) and another problem is oil consumption 1 Qt per thousand miles that is also common. You would think acura would stand behind the motor rattle and oil use issue BUT NO. That will not happen. I OWN KIA'S GREAT CARS I drive them like I stole em. Good Luck to you sir and have a wonderful day. Yankee
 
1 - 5 of 5 Posts
Top