Acura TSX Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
207 Posts
Discussion Starter #1
So recently when i turn my low beams on, the passenger side only stays on for a minute or two then it shuts off. but if i were to shut it off and re-open them, sometime only the passenger goes on and the driver is off.

i've checked the fuses and the wiring, everything seems to be fine. i even unplugged my foglights. My headlights got no condensation or problems.

what could be the issues?

thanks
dave
 

·
Premium Member
Joined
·
857 Posts
Your ballasts are going. You need to replace them. The cheapest alternative would be to either buy an aftermarket ballast from somewhere like DDM Tuning or a junk yard. The best and most expensive option would be directly from the dealer.
 

·
Somaek juseyo?
Joined
·
1,291 Posts
Your ballasts are going. You need to replace them. The cheapest alternative would be to either buy an aftermarket ballast from somewhere like DDM Tuning or a junk yard. The best and most expensive option would be directly from the dealer.
My passenger one flickers every so often and has gone out once. You think the ballasts are the same cause?
 

·
VP of Infinite Infinity
Joined
·
1,791 Posts

·
Somaek juseyo?
Joined
·
1,291 Posts

·
Premium Member
Joined
·
857 Posts
Rarely do HID bulbs burn out. They either don't turn on at all or they have a tint of purple. The usual piece that goes is the ballast which is what you've scribed is happening. Sometimes the ignitor (ballast) won't ignite the bulb.
 

·
Registered
Joined
·
283 Posts
i had a similar problem. The driver side would turn on for so long the n shut off and when turning it back it back on it would repeat the same thing. Change the halogen.

other symptoms were pinkish color. I suggest changing both so they dont look weird.

Its your bulb though... good luck
 

·
Registered
Joined
·
207 Posts
Discussion Starter #9
i had a similar problem. The driver side would turn on for so long the n shut off and when turning it back it back on it would repeat the same thing. Change the halogen.

other symptoms were pinkish color. I suggest changing both so they dont look weird.

Its your bulb though... good luck
as meek said, i changed the bulb and it's all good now, no need for a new ballast, i got a spare now that i don't need =/
 
1 - 9 of 9 Posts
Top