Acura TSX Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Car is 04 6speed Manual
I recently added a Skunk 2 Pro Series Intake Manifold, a Grams 72mm throttle body, a Skunk 2 composite fuel rail and DC shorty headers. These were in addition to pre existing mods, Random Technologies high flow Cat, K & N cold air intake, full Skunk 2 bolt on exhaust.

Here is the problem I'm having;

I've noticed since the new addition of parts that sometimes the car will fire right up the first time, other times you have to try a few times to get it to start. However if I put the key in the "on" position for a few seconds before starting it, it seems to fire every time. Could this be a fuel problem? I'm wavering between needing a better fuel pump or needing a new starter, as it is the factory starter. But this didn't happen until I got that fuel rail. Any thoughts or suggestions would be greatly appreciated. Thanks :)
 

·
Registered
Joined
·
256 Posts
the fuel rail is the issue, it seems that your fuel rail isn't holding pressure and you have to prime the pump before it will turn over.

did you use new gaskets with the fuel rail when you installed the injectors?
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #3 ·
Yes, we did use new gaskets. Sometimes when it doesn't start, the starter doesn't even spin or click as if the battery is dead. But then you wait about 10-20 seconds and try again and it starts like it has a new battery in it. Maybe a dead spot in starter? It is the oem Honda starter.
 
1 - 3 of 3 Posts
Top