Acura TSX Forum banner

1 - 6 of 6 Posts

·
owned ur ass
Joined
·
200 Posts
Discussion Starter · #1 ·
Well there seems to be a loud rubbing sound, like metal and metal, coming from my front passenger side tire. I believe it was from the meguairs rims spray cleaner from getting on the rotor area. Anyone have any ideas on how to get it to go away? It only happens at low speeds and ussually happens when the brakes and rotors are cool. It also ussually goes away when i exceed 20 mph. Would brake cleaner fix this problem or do you guys have any other ideas?
 

·
UK Accord Type-S
Joined
·
109 Posts
may have taken away the grease from the backplate of the pads?? causing them to vibrate? May jst need to have some copper grease applied to the back of the brake pads.
 

·
owned ur ass
Joined
·
200 Posts
Discussion Starter · #3 ·
will give it a try thanks
 

·
Registered
Joined
·
16 Posts
it depends what kind of pads you are running. Some pads with higher metallic compounds may produce such a sound. Another time that happens is when the brakes have been worn into the backing plate.
 

·
Registered
Joined
·
6 Posts
I had a rock in my backing plate that caused the sound you mentioned above. It got so load, eventually when the rock flew out it was like the grand finale of sounds.
 

·
What to put here?
Joined
·
1,990 Posts
I had something similar happen to me with the backing plate rubbing against the rotor. I just pushed the thin backing plate away from the rotor a little and the sound went away. :donno: The dealer didn't have a clue of what caused this to happen so they replaced the front brake pads.
 
1 - 6 of 6 Posts
Top