Acura TSX Forum banner

1 - 6 of 6 Posts

·
ummm what?
Joined
·
258 Posts
Discussion Starter #1
i have noticed in recent weeks that once vehicle starts it idles rough unless i tap throttle and it levels out. starts quick and fine but idles poor. now i have gotten a p0303 code,swapped coil to another cylinder and it return to cyl 3. i checked plug and its perfect. im at 106600 plugs changed about 99k. i use 92+ octane. i cleaned the throttle body as that could cause it but it didnt change.

any ideas?
 

·
Triple Platinum Member
Joined
·
598 Posts
i have noticed in recent weeks that once vehicle starts it idles rough unless i tap throttle and it levels out. starts quick and fine but idles poor. now i have gotten a p0303 code,swapped coil to another cylinder and it return to cyl 3. i checked plug and its perfect. im at 106600 plugs changed about 99k. i use 92+ octane. i cleaned the throttle body as that could cause it but it didnt change.

any ideas?
when you say cleaned the throttle body, do you mean the inside of the throttle body or the electrical connections?

I was surprised to find corrosion inside the DBW wiring harness, but I got to cleaning this because I was getting CEL's at increasing frequency due to throttle body position not learned at startup. this was not so fun because the car idles very high while this was going on, and did not respond to the throttle. clearing the code made it work normally again, but idle was always crappy during this time, and once the connections were clean it became much smoother. the CEL's stopped. iirc, the throttle gets opened around 18% by the ecu on a cold start, so it is important to for the ecu to have good communication/feedback (control) over the throttle body.

if you decide to clean those connections, please let me know if this helps!
 

·
ummm what?
Joined
·
258 Posts
Discussion Starter #3
DBW??

i cleaned the inside blade. i havent had code in awhile but when talking to people they say mass air flow sensor. we dont have one.
 

·
Registered
Joined
·
184 Posts
oh man! "Throttle Body and Nissan" not a good combo! I cleaned out my mom's throttle body on her 2005 Nissan Sentra, was I shitting bricks after starting it! The RPM's where going from 1500 and 2000 on idle (P and N) but while in (R, D, 2, and 1) it was fine. I end up taking to LexService (aka Japanese Car Clinic). Turns out I didn't [email protected] up the throttle body! What a relief! The ECU need to "relearn" the air absorption. So the lesson here is am never cleaning a throttle body on a Nissan/Infiniti with drive-by-wire system!...hehe

I would just drive around and it should go back to normal.
 
1 - 6 of 6 Posts
Top